PDA

View Full Version : Problem with tab indexes...



eponymous
18 Sep 2008, 10:47 AM
Hi, I have a problem with tab indexes in a window when I have more than one window opened...If I open a window the tab indexes are ok, but if I open another window from that window, then the cursor goes from child window to parent window, then comes back to child window and so on...is this a bug or am I doing something wrong???

Thanks in advance!

gslender
18 Sep 2008, 12:23 PM
not sure I follow you - can be more descriptive and would be better if you can show a screenshot or post a code example that demonstrates the problem

eponymous
18 Sep 2008, 12:40 PM
Ok, I'll try to be more descriptive.

SCENARIO A (Works):

"Let's say I have a window A. If I open window A from main page and hit the tab key the cursor follows the order I've specified for each of the controls using setTabIndex()."

SCENARIO B (Works):

"Let's say I have a window B. If I open window B from main page and hit the tab key the cursor follows the order I've specified for each of the controls using setTabIndex()."

SCENARIO C (Fail):

"Let's say I have two windows, A and B. If I open window A from main page and hit the tab key the cursor follows the order I've specified for each of the controls using setTabIndex(). Now, if I open window B from window A and hit the tab key, the cursor appears in the first control of window B, if I hit tab again, the cursor goes into window A's first control, hit tab, goes to window B's second control, hit tab, window A's second control, hit tab, window B's third control, etc, etc, etc."

Is like in this case, though window B is opened as modal, it is not blocking the input in window A, so the cursor goes back and forth between window A and window B. This is not happening if you open just one of the windows from application's main page.

gslender
18 Sep 2008, 12:52 PM
ok, sounds like a bug - if possible, post this and perhaps a sample example to the bug forum