PDA

View Full Version : Error only under Linux GXT 1.2.4



marman
1 May 2009, 12:10 PM
I build the same code fine on Windows, however it fails on my Ubuntu 9.04 workstation. I am under GWT 1.5.3 and GXT 1.2.4





[ERROR] Errors in 'jar:file:/home/projects/.m2/repository/com/extjs/gxt/gxt/1.2.4/gxt-1.2.4.jar!/com/extjs/gxt/ui/client/mvc/Dispatcher.java'
[ERROR] Line 240: The method newItem(String) in the type History is not applicable for the arguments (String, boolean)

marman
7 May 2009, 4:14 AM
no one else has seen this under Linux?

marman
7 May 2009, 6:41 AM
I tried my build on our build server (Windows Server 2003) and same problem. I did a clean checkout on my dev machine and that build fine. I am using the same JDK version on all the boxes.

This is a *MAJOR* issue for me and i am really in a bind to understand why my build will not work on another machine. The error makes no sense to me.

Martin.Trummer
8 May 2009, 12:43 AM
just a guess
since the History.newItem() is gwt-stuff:
maybe another gwt version may be used on the failing server