PDA

View Full Version : [FIXED][3.0RC1.1+] disableCaching broken



tryanDLS
11 May 2009, 12:30 PM
When passing nocache:false from an Updater, Connection will step on the value and always add the cache-buster. In Connection.request me.disableCaching=true and will always cause the parm to be added.


if(method == GET && (me.disableCaching || o.disableCaching !== false)) {// || o.disableCaching === true){
var dcp = o.disableCachingParam || me.disableCachingParam;
url += (url.indexOf('?') != -1 ? '&' : '?') + dcp + '=' + (new Date().getTime());
}




Ext.get('testdiv').load({url:'test.html', nocache:true}); <- true/false both send dc=....

aconran
18 May 2009, 8:31 AM
This is fixed in SVN.

Juanito
1 Oct 2009, 7:43 PM
This bug is still present in ext-core.There is something wrong with the 3rd party API I am using that is causing it to randomly timeout my Ajax requests because of the extra parameter (don't understand how that's possible). I've patched my ext-core-debug.js and am using that instead.

Is this going to be addressed?

evant
1 Oct 2009, 7:49 PM
Are you saying it's still present in the current SVN code, or in the latest release?

leandrorc
21 May 2010, 4:56 PM
I tested disableCaching:true right now with ext 3.2.1, and the cache-buster is not added!