PDA

View Full Version : Missing information on Ext-GWT product pa



ronaldmathies
17 May 2009, 8:50 PM
What i miss on the Ext-GWT product page is version compatibility, which version of Ext-GWT works with which version of ExtJS and GWT.

Does anybody have a clue with what version of ExtJs and GWT can be used with the latest Ext-GWT release? (Ext GWT 2.0 M1 SDK and Ext GWT 1.2.4 SDK)

micgala
18 May 2009, 12:34 AM
Hi.

GXT is NOT dependent on ExtJs... at all.

GXT 2.x works with GXT 1.6 only.
GXT 1.x works with GXT 1.5

Regards,
Michel.

ronaldmathies
18 May 2009, 12:38 AM
I think you mean:

GXT 2.x works with GWT 1.6 only.
GXT 1.x works with GWT 1.5

Right?

So if i understand correctly, GXT is a GWT compiled version of ExtJS so it includes the ExtJS code. Thats wonderfull..

micgala
18 May 2009, 12:52 AM
Yes:

GXT 2.x works with GWT 1.6 only.
GXT 1.x works with GWT 1.5

And no, GXT is really not related to ExtJs.
I mean, they are very similar, and they want to share the same features...

But GXT has not ext base code inside...
It is completely built based on Java/GWT.

What this means is:
GXT has not a dependency to ExtJs code.

ronaldmathies
18 May 2009, 12:55 AM
Ah oke, that makes it a lot clearer... i used to work with the GWT-Ext library which wrappes ExtJS for GWT. Thats why i got a bit confused.