PDA

View Full Version : [FIXED] Slate buttons rendering funny in GXT 2.0



rsmith59
27 May 2009, 5:41 AM
I am having difficulty getting buttons to render correctly for the Slate theme for GXT v.2.0(m2). They appear white and light blue on hover instead of the darker slate color. Anyone else notice this? It works for 1.2, but not 2.0.

sven
27 May 2009, 5:57 AM
2.0 is currently not supporting the slate theme currectly. Many things have changed for 2.0. 2.0 is not backward compatible.

moldoe
27 May 2009, 7:21 AM
Is the Slate theme going to be supported when 2.0 final is released?

Thanks,

Daniel

mindstream
26 Jun 2009, 9:59 AM
For those of us counting on Slate, this is important. Is Slate being dropped from 2.0? If not, will it be ready for Release?

Thanks.

darrellmeyer
3 Jul 2009, 11:52 AM
Slate theme will be supported in 2.0. We have added and updated the missing styles in SVN. Changes will be in the 2.0 release.

http://extjs.com/examples-dev/explorer.html#advancedtoolbar

ocooper
7 Jul 2009, 4:04 AM
We are working with the latest version of the 2.0 release from the repository and Slate buttons still aren't rendering correctly - see the image below. The button text is white and therefore almost unreadable and mouseover is blue.

http://oasp-beta.athensams.net/oalahelp/OALAHelp/screenshot.png

We would really appreciate it if you would be able to give us some sort of idea of when this is likely to get fixed - having been told Slate will be supported we have proceeded with our design on the assumption that our product will have that look & feel.

Many Thanks,

Oli Cooper.

sven
7 Jul 2009, 4:12 AM
You also need to update your css and images. The buttons looks much different in the 2.0 final release.

ocooper
7 Jul 2009, 4:46 AM
Ooops, sorry :">