PDA

View Full Version : Errors in : gxt-2.0-M3.jar!/com/extjs/gxt/ui/client/widget/menu/Menu.java



jamelboubaker
30 Jun 2009, 1:27 AM
when i run my application in eclipse "Project gxt with maven 2"

it show some errors like that :

[ERROR] Errors in 'jar:file:/C:/Documents%20and%20Settings/552885/.m2/repository/com/extjs/gxt/2.0-M3/gxt-2.0-M3.jar!/com/extjs/gxt/ui/client/widget/menu/Menu.java'

[ERROR] Errors in 'jar:file:/C:/Documents%20and%20Settings/552885/.m2/repository/com/extjs/gxt/2.0-M3/gxt-2.0-M3.jar!/com/extjs/gxt/ui/client/widget/form/NumberField.java'

[ERROR] Errors in 'jar:file:/C:/Documents%20and%20Settings/552885/.m2/repository/com/extjs/gxt/2.0-M3/gxt-2.0-M3.jar!/com/extjs/gxt/ui/client/event/TreePanelEvent.java'

[ERROR] Line 63: The method getEventTarget() is undefined for the type Event




im sure that the gxt-2.0-M3.jar is imported to my project by maven2.

can you help me to find solution!
Thanks

sven
30 Jun 2009, 1:36 AM
Moving this to the help forum.

Are you sure that you use gwt 1.6.4?

jamelboubaker
30 Jun 2009, 3:26 AM
I would like to know what is the difference between 2.0 and 1.6.4 ?
i use 2.0 version !

Thanks

sven
30 Jun 2009, 3:27 AM
You use GWT2? GWT2 is not yet released. I suggest to use GWT 1.6.4

jamelboubaker
30 Jun 2009, 3:45 AM
in my pom xml i do like that:

<!-- convenience to define GWT version in one place -->
<properties>
<gwtVersion>1.6.4</gwtVersion>
</properties>

<!-- GWT deps (from central repo) -->
<dependency>
<groupId>com.google.gwt</groupId>
<artifactId>gwt-servlet</artifactId>
<version>${gwtVersion}</version>
<scope>runtime</scope>
</dependency>

<dependency>
<groupId>com.google.gwt</groupId>
<artifactId>gwt-user</artifactId>
<version>${gwtVersion}</version>
<scope>provided</scope>
</dependency>

<dependency>
<groupId>com.google.gwt</groupId>
<artifactId>gwt-dev</artifactId>
<version>${gwtVersion}</version>
<classifier>${platform}-libs</classifier>
<type>zip</type>
</dependency>

<dependency>
<groupId>com.google.gwt</groupId>
<artifactId>gwt-dev</artifactId>
<version>${gwtVersion}</version>
<classifier>${platform}</classifier>
</dependency>


<!--For-GXT-->
<dependency>
<groupId>com.extjs</groupId>
<artifactId>gxt</artifactId>
<version>2.0-M3</version>
</dependency>


Conclusion: i use gwt 1.6.4 and gxt 2.0
i trouve the same error!
Thanks!