PDA

View Full Version : Is Ext GWT 2.0 compatible with GWT 1.7?



estevaofreitas
15 Jul 2009, 6:23 AM
I would like to thank all the Ext Gwt developers for the great modifications of the new version.
But, I didn`t find anywhere if the Ext Gwt 2.0 is compatible with GWT 1.7. Can I just replace the GWT jar file at the project?

fother
15 Jul 2009, 6:25 AM
yes!

sven
15 Jul 2009, 6:26 AM
It is not 100% compatible. 2.0.1 will be compatible. The changes are already in svn.

fother
15 Jul 2009, 6:41 AM
I execute all my test case using 1.7 and passed in all..

micgala
15 Jul 2009, 6:48 AM
Do we have any prevision date for the release of gxt 2.0.1?

sven
15 Jul 2009, 9:01 AM
I execute all my test case using 1.7 and passed in all..

There was a new DeferredBinding added to GWT 1.7. That is also the reason why it is marked as 1.7 and not 1.6.5. So it is possible that it is not backward compatible. The change to make GXT2 fully compatible to GWT 1.7 is already in SVN.

fother
15 Jul 2009, 9:10 AM
hmm.. I dont have test case with DeferredBinding rsss