PDA

View Full Version : Visual Studio .NET 2008 Intellisense not working



mohaaron
29 Jul 2009, 1:35 PM
I'm just added Ext-Core-3.0 to my asp.net project and when trying to get the intellisense working I get this error. Does anyone know what the problem here is?

Warning 1 Error updating JScript IntelliSense: "Scripts\ext-core-3.0\ext-core-debug.js: 'Ext.util' is null or not an object @ 421:0"

tryanDLS
29 Jul 2009, 2:31 PM
Suggest you search for the existing thread regarding this. I would think the discussion applies to Core the same as Ext base.

mohaaron
29 Jul 2009, 9:22 PM
I don't know, I've been using ext base for a while with no problems. I have also done extensive searching on VS.NET intellisense in the recent past and have not had this same problem with ext base.

shovon
30 Jul 2009, 4:32 AM
Since I upgraded my VS2008 Beta2 to the RTM, the intellisense has not been working. I have seen a few posts about this, some suggesting you need to reset the configuration by running
but this did not work for me.
So I had a poke about in Tools|Option and found that on the Text Editor|All Languages that the three checkboxes for Statement Completion where showing neither empty or checked but a fully colored box - which usually means an unknown settings. So a set these all to checked (a tick) and my Intellisense started working.

--------------------------------------------
Ashley Madison (http://productreviewsby.me/ashley-madison-review/)

mohaaron
30 Jul 2009, 10:13 PM
I just checked my VS.NET settings and this is not my problem. The settings you mention just normally checked check boxes. I can also say that intellisense works fine once I remove the ext-core-debug.js javascript reference from the file and then use Ctrl+Shift+J to get the js files read for intellisense. So I am pretty sure the problem is in the ext-core-debug.js js file.