PDA

View Full Version : [2.0.1] EditorGrid CheckBox Selection Issue



markrgli
2 Aug 2009, 10:09 PM
Hello guys,

I've got another weird problem when running my GXT application in IE8 (and sometimes in Hosted Mode). Here's the scenario:

* I have a panel containing an EditorGrid with a checkbox column (CheckBoxSelectionModel).
* I have an RPC service to retrieve the data from the server and load it into the grid.
* Data consists of a list of items that are to be loaded (added as rows) into the grid and a list of items that are to be selected (using the CheckBoxSelectionModel) in the grid.
* When the panel is opened, the service is called to retrieve the data. Once the data is received, the items are first loaded and then some items are selected based on some information in the data. Masking is done before calling the service and after loading and selecting the data in the grid.

The problem is that there are times when the data is loaded and selected but after unmasking, the grid's selection is cleared. Sometimes it occurs when you move the mouse over the grid while still loading (still in masked state) and sometimes it just occurs even without you doing anything.

I can't post the actual source code due to NDA and because it requires some dependencies but I'm working on a simple test case but it doesn't replicate the issue yet. Will post the test case once ready. For now, I'm posting this just in case someone else has had a similar experience. It's really weird and I've been trying to figure out the cause for weeks now and yet to no avail.

Thanks for looking, guys.

GWT: v1.7.0
GXT: v2.0.1
IE: v8
OS: Windows XP

Regards,
Mark

sven
3 Aug 2009, 12:26 AM
Moved this to help forum for now so that more people see it.