PDA

View Full Version : Ext-1.1-beta1 svn errors after update to rev 596



nassaja-rus
25 Jun 2007, 12:15 AM
E has no properties
initDocReady() ext-all-debug.js (line 1773)
onDocumentReady(function(), undefined, undefined) ext-all-debug.js (line 2013)
[Break on this error] E.on(window, "load", fireDocReady);
ext-all-debug.js (line 1773)




Ext.state.Manager has no properties
init() init.js (line 33)
fire() ext-all-debug.js (line 1707)
fireDocReady() ext-all-debug.js (line 1743)
[Break on this error] Ext.state.Manager.setProvider(new Ext.state.CookieProvider());

nassaja-rus
25 Jun 2007, 12:23 AM
All fine with rev 589, but after rev 590 i have this bugs. I build ext with java builder

rtannert2
25 Jun 2007, 6:23 AM
I'm using the Java builder on my Mac. I'm not having any trouble building 1.1b1 in rev 596, but in 2.0 (in rev 596) I see that ext-base.js has been moved from the src/experimental folder to the src/adapter folder, but ext.jsb has not been updated. It appears


<target name="Ext Base" file="$output\adapter\ext\ext-base.js" ...>
<include name="core\Ext.js" />
<include name="experimental\ext-base.js" />
</target>

should now be


<target name="Ext Base" file="$output\adapter\ext\ext-base.js" ...>
<include name="core\Ext.js" />
<include name="adapter\ext-base.js" />
</target>

tryanDLS
25 Jun 2007, 8:42 AM
Just built both branches with 598 and it looks like it's fixed.

rtannert2
25 Jun 2007, 9:51 AM
Thanks, Tim.

nassaja-rus
25 Jun 2007, 11:34 AM
I can't understend why, but i have only this:



<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title></title>

<link rel="stylesheet" type="text/css" href="/js/ext/resources/css/reset-min.css">
<link rel="stylesheet" type="text/css" href="/js/ext/resources/css/ext-all.css">

<script type="text/javascript" src="/js/ext/adapter/ext/ext-base.js"></script>
<script type="text/javascript" src="/js/ext/ext-all-debug.js"></script>

</head>
<body>

<div id="mainNorth" class="xlayout-inactive-content">
<div id="main-menu"></div>
</div>

<div id="mainCenter" class="xlayout-inactive-content">
</div>

</body>
</html>


and i have



E has no properties
[Break on this error] E.on(window, "load", fireDocReady);


error in line 1773. Linux, firefox 2.0.5, java jsbuilder, svn r602.

nassaja-rus
25 Jun 2007, 11:39 AM
There some problem with ext-base.js adapter. When i use yui adater - all fine with last svn rev.

mdissel
25 Jun 2007, 12:14 PM
There some problem with ext-base.js adapter. When i use yui adater - all fine with last svn rev.

See post of rtannert2, search for ext-base.js in the ext.jsb and make sure it's pointing to adapter instead of experimental directory.

Thanks
Marco

nassaja-rus
25 Jun 2007, 12:20 PM
See post of rtannert2, search for ext-base.js in the ext.jsb and make sure it's pointing to adapter instead of experimental directory.

Thanks
Marco

Yes! Sorry, this trouble in ext.jsb