PDA

View Full Version : GWT 2.0.0RC1 and GXT 2.0.1



toedter_k
19 Nov 2009, 7:03 AM
Hi All,

I tried the forum search but I did not find anything...
My project compiles and runs perfectly with GWT 1.7 and GXT 2.0.1.

I just tested GXT 2.0.1 with GWT 2.0.0RC1 and get errors like

Validating newly compiled units
[ERROR] Errors in 'jar:file:.../war/WEB-INF/lib/gxt.jar!/com/extjs/gxt/ui/client/widget/Component.java'
[ERROR] Line 1417: Cannot reduce the visibility of the inherited method from Widget

and

Resolving com.extjs.gxt.ui.client.event.TreeGridEvent
Found type 'com.extjs.gxt.ui.client.event.TreeGridEvent'
Found type 'com.extjs.gxt.ui.client.event.GridEvent'
Found type 'com.extjs.gxt.ui.client.widget.grid.Grid'
[ERROR] Unable to resolve class com/extjs/gxt/ui/client/widget/BoxComponent

Did I miss something in the compiler configuration?
Is it planned to support GWT 2.0?

Thanks

Kai

sven
19 Nov 2009, 7:04 AM
This is due to public api changes in GWT2. It should be expected that you cannot just switch major versions.

You will need to use GXT 2.0.3 or above.

toedter_k
19 Nov 2009, 7:09 AM
Thanks Sven,

I have already ordered a gxt subscription, but (due to processes in bigger companies :)) it may take a while until you get the order...

As soon as I can download 2.0.4 or higher I will give it another try.

sven
19 Nov 2009, 7:16 AM
2.1 which will be there soon does also support it.

We adjusted the code right after the change for GWT hit the GWT svn.

Arno.Nyhm
19 Nov 2009, 7:51 AM
is it planet to use this part available for GXT?


* Declarative User Interface: GWT's UiBinder now allows you to create
user interfaces mostly declaratively. Previously, widgets had to be
created and assembled programmatically, requiring lots of code. Now,
you can use XML to declare your UI, making the code more readable,
easier to maintain, and faster to develop. The Mail sample has been
updated to use the new declarative UI.
Source: http://groups.google.com/group/google-web-toolkit/browse_thread/thread/8b79ebe444b9126d

sven
19 Nov 2009, 8:00 AM
This was discussed before. GXT 2.X cannot support this because of backward compatibility. The first version to look into this would be GXT 3.

msauter
4 Jan 2010, 1:40 AM
Any updates available to GXT 3.0 ? I need this UiBinder feature.

bobpardoe
25 Jan 2010, 11:42 PM
Just starting a GWT project and want to use all the GWT 2.0 goodess including your widget set.

Release v3.0 with uiBinder support and we will order 5 licenses !

I too would like to know what your approximate v3 release timelines are please.

BOb

Pierre Havelaar
3 Feb 2010, 6:11 AM
Hi all,

I have just started playing with the new GXT 2.1.1 for GWT 2.0 and I was able to use UIBinder and GXT widgets together.
I noticed that in order to define widgets in a GXT Container instead of a GWT Panel all that is needed is that Container implements the interface HasWidgets. I tried to extend a ContentPanel to implement the HasWidgets interface, but it wasn't possible only because of one difference: method add() returns boolean instead of void.
I would be great if this change could be made to Container so we can use all of GXT's container classes in the UIBinder xml.

Thanks for the good work!

raoul
20 Feb 2010, 10:14 AM
We are developping several web applications for our company and we really need the UIBinder compatibilty with the GXT components. Do you know when GXT3.0 is coming?

fvisticot
17 Mar 2010, 5:20 AM
I'm very insterested as well for UIBinder feature.
Any roadmap regarding GXT3.0 (nothing in the website roadmap...).

Fred

rlaferla
19 Mar 2010, 7:19 AM
We also want to use UIBinder. When can we start using it with GXT?

clarke
26 Apr 2010, 6:15 AM
We also are interested in UiBinder support.

sven
26 Apr 2010, 6:19 AM
We also want to use UIBinder. When can we start using it with GXT?

There is no API yet in GWT to register own parsers.

vkovalenko
28 Jan 2013, 8:16 AM
Hello, guys, I know it has been almost 3 years since last post in this thread, but I'll take my chance. So my problem is that in my project i've used GWT 1.7 and GXT 2.0.1. Now I decided to upgrade to GWT 2.0.0 and I wanna ask which version of GXT should I use to not brake any compability?

Colin Alworth
29 Jan 2013, 9:20 AM
The GXT download zip includes three different jars - one for GWT 1.7, one for GWT 2.0-2.1, and one for GWT 2.2 and beyond. Use the one labeled -gwt2 to work with GWT 2.0.