PDA

View Full Version : Problem with 2.1



soact
25 Nov 2009, 2:46 AM
Hello

As 2.1 is released i used it in my projects,

But there is a serious problem
As i extended the Contentpanel or LayoutContainer as ContentPanelTemplate or LayoutContainerTemplate so i could create some extra functions in it.

also i used the .setLayoutData(TheData) ( the protected one )
This is gone ??????

Why

Please respond

sven
25 Nov 2009, 3:42 AM
Due to public API changes in GWT, you can use ComponentHelper. You should read the release notes before updating.

soact
25 Nov 2009, 4:13 AM
Sven,

thx for the quick response,
I changed it from the contentpaneltemplate etc..
to setlayoutData(this,thedata)

is this OK,

regards toine