PDA

View Full Version : EXT GWT backward compatibility



Priyams
10 Dec 2009, 10:47 AM
Hi,

Is GWT 2.0 backward compatible with 1.x?

TheBuzzer
11 Dec 2009, 12:01 PM
there are changes that need to be done but it shouldnt be that hard. most features are still there.

tbenbrahim
14 Dec 2009, 7:22 PM
Code written in 1.6/1.7 will compile without problem in GWT 2.0

Code written to take advantage of new 2.0 features (RunAsync, ResourceBundle, etc...) will obviously not compile in 1.X

Tony

darrellmeyer
15 Dec 2009, 3:18 PM
Ext GWT 2.1 is compatible with GWT 2.0. We have been monitoring the earlier releases of GWT 2.0 to making to ensure the Ext GWT code worked with GWT 2.0.

However, there is one change that you will need to make to use GWT 2.0. See the following post (http://www.extjs.com/forum/showthread.php?p=412673) which describes the change you will have to make to run GWT 2.0 with GXT 2.1.

Ext GWT 2.X will continue support for both GWT 1.7 and GWT 2.0. Ext GWT 3.0 will only support GWT 2.0+ and will take advantage of the new features in GWT 2.0.