PDA

View Full Version : [3.X.X] Aptana plugin



seek
11 Jan 2010, 2:01 AM
Hi people,
here my first version of Aptana plugin for ExtJs 3.X.X.
Comments, suggestions and flames are welcome! :D

Download plugin for ExtJs 3.0.3 from: MegaUpload (http://www.megaupload.com/?d=ZKO24N2Q) - RapidShare (http://rapidshare.com/files/334132604/com.extjs.ext.3.0_3.0.3.00001.jar.7z)

Download plugin for ExtJs 3.1.0 rev. 0002 from: MegaUpload (http://www.megaupload.com/?d=9UADG1IA) - RapidShare (http://rapidshare.com/files/337154672/com.extjs.ext.3.1_3.1.0.0002.jar.7z.html)
- Smaller package (delete useless files)

Download plugin for ExtJs 3.1.0 rev. 0003 from: MegaUpload (http://www.megaupload.com/?d=MUWWQ5NJ) - RapidShare (http://rapidshare.com/files/338264257/com.extjs.ext.3.1_3.1.0.0003.7z)
- Fixed package dependencies
Known bugs:
- Problem with help window

Download plugin for ExtJs 3.1.1 rev. 0001 from: MegaUpload (http://www.megaupload.com/?d=15CTHM6U) - RapidShare (http://rapidshare.com/files/369830707/com.extjs.ext.3.1_3.1.1.0001.7z)

Download plugin for ExtJs 3.2.0 rev. 0001 from: MegaUpload (http://www.megaupload.com/?d=JC4JTDTQ) - RapidShare (http://rapidshare.com/files/372599478/com.extjs.ext.3.2_3.2.0.0001.7z)

Download plugin for ExtJs 3.2.1 rev. 0001 from: MegaUpload (http://www.megaupload.com/?d=G8NNNG1W) - RapidShare (http://rapidshare.com/files/422293965/com.extjs.ext.3.2.1_3.2.1.0001.jar.7z)

Download plugin for ExtJs 3.2.2 rev. 0001 from: MegaUpload (http://www.megaupload.com/?d=LM5Z26X2) - RapidShare (http://rapidshare.com/files/424904748/com.extjs.ext.3.2.2_3.2.2.0001.jar.7z)

Download plugin for ExtJs 3.3.0 rev. 0001 from: MegaUpload (http://www.megaupload.com/?d=DHY6YUL0) - RapidShare (http://rapidshare.com/files/424906011/com.extjs.ext.3.3.0_3.3.0.0001.jar.7z)

Installation instructions for Eclipse and Aptana Studio
Just decompress with 7zip, and place jar file in PLUGINS subdir or in DROPINS subdir.
Detailed instruction for Eclipse here (http://www.extjs.com/forum/showthread.php?p=433230#post433230) by JAnderson (http://www.extjs.com/forum/member.php?u=55922)

SUPPORT IT!! (https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=claudio%2epalladini%40gmail%2ecom&lc=IT&currency_code=EUR&bn=PP%2dDonationsBF%3abtn_donate_SM%2egif%3aNonHosted)

Seek

Thanks to the first contributor: Scott

Stju
11 Jan 2010, 10:02 AM
Looks very promissing!
Great JOB! B)

muratyildiz
11 Jan 2010, 1:11 PM
Can you upload this plugin another site? Rapid ?

Foggy
11 Jan 2010, 1:28 PM
Sounds promising, unfortunately i cant download the file too...
Thanks in advance.

sexy22
11 Jan 2010, 7:53 PM
great job!
Thanks advanced!

seek
12 Jan 2010, 12:46 AM
great job!
Thanks advanced!

If you have Aptan 2.X.X, you can copy it in the "dropins" subdir, otherwise, if you have 1.x.x version, you must copy it in the standard plugin subdir.

seek
12 Jan 2010, 12:50 AM
It's nothing of special, just only an attempt to update the old Aptana plugin for Ext 2.2.0... :-?

muratyildiz
12 Jan 2010, 6:10 AM
Thanks

wemerson.januario
12 Jan 2010, 6:23 PM
sounds promissing. I will test

swarm
15 Jan 2010, 3:46 AM
Seems to work really well - nicely done! Thanks

JHannes
17 Jan 2010, 1:36 AM
Hey Guys...

can anyone tell me how to add this plugin as a Aptana AJAX Library (or JavaScript Environment) for code completion? I'm using Aptana as a plugin in Eclipse PHP Galileo SR1 Linux. I've found nothing in Window > Preferences > Aptana and I couldn't get it working over Help > Install New Software...

Is there something like a config file where I can add this plugin?

Cheers
JHannes

sexy22
17 Jan 2010, 7:09 PM
thanks!I have solved the problem:)

Tháles
27 Jan 2010, 12:35 PM
Hey Guys...

can anyone tell me how to add this plugin as a Aptana AJAX Library (or JavaScript Environment) for code completion? I'm using Aptana as a plugin in Eclipse PHP Galileo SR1 Linux. I've found nothing in Window > Preferences > Aptana and I couldn't get it working over Help > Install New Software...

Is there something like a config file where I can add this plugin?

Cheers
JHannes

Same here! Is there a way to update the libraries for Aptana as a plugin in Eclipse?

Thanks in advance!

seek
28 Jan 2010, 2:31 AM
Same here! Is there a way to update the libraries for Aptana as a plugin in Eclipse?

Thanks in advance!

Try to place jar file in PLUGINS subdir or in DROPINS subdir, but I have not tested it with Eclipse...
HTH

Seek

seek
2 Feb 2010, 1:49 AM
Someone have ideas about licensing & similar?
This is my first free tool...

JAnderson
2 Feb 2010, 9:29 AM
Same here! Is there a way to update the libraries for Aptana as a plugin in Eclipse?

Thanks in advance!

1 - Close Eclipse
2 - Copy the JAR file into .\eclipse\dropins\
3 - Open Eclipse and goto Window -> Preferences -> Apatana -> Editors -> JavaScript -> Code Assist
4 - You should see Ext 3.0 in the JavaScript Environments list, check the box and click OK

Should be good to go after following these steps

And to the author, thanks for this plugin. It's great!

seek
3 Feb 2010, 1:39 AM
1 - Close Eclipse
2 - Copy the JAR file into .\eclipse\dropins\
3 - Open Eclipse and goto Window -> Preferences -> Apatana -> Editors -> JavaScript -> Code Assist
4 - You should see Ext 3.0 in the JavaScript Environments list, check the box and click OK

Should be good to go after following these steps

And to the author, thanks for this plugin. It's great!

Thanks JAnderson.
I link your instructions in the first post

Seek

dimentox
4 Feb 2010, 6:11 PM
Which is typically better aptana or spket? i use spket and bought it.

jerrel
19 Feb 2010, 3:31 PM
Hi Guys,

I receive this error when trying to create the air app.

Any idea how to resolve this ?

regards
J

marcostimm
5 Mar 2010, 11:51 PM
:))

Very Thanks!

I`ll test right now!

asagala
7 Mar 2010, 8:23 PM
Tried installing this in Zend Studio (based on Eclipse) using the method described above but cant get Apatana menu to appear. Anyone tried this successfully?

Sesshomurai
19 Mar 2010, 6:53 AM
What can you do with this plugin? Any examples you can post here to help understand is appreciated.

cginzel
20 Mar 2010, 2:37 PM
@seek how did you figure out how to build this plug-in? i'd like to move up to the 3.1.1 release and it would be cool to be able to built it myself anytime i needed to upgrade.

seek
23 Mar 2010, 12:37 AM
@seek how did you figure out how to build this plug-in? i'd like to move up to the 3.1.1 release and it would be cool to be able to built it myself anytime i needed to upgrade.

I'm working on it ;)

waitingmyself
25 Mar 2010, 1:21 AM
great !
but is there any one for spket

Eric Suen
25 Mar 2010, 11:19 AM
great !
but is there any one for spketWhat is your means, Spket already support Ext 3.x.x

mpawlowski
25 Mar 2010, 1:35 PM
Works great, thanks :)

waitingmyself
25 Mar 2010, 10:03 PM
What is your means, Spket already support Ext 3.x.x

:"> i saw
i am still in using 2.2

Bulle Bas
27 Mar 2010, 7:35 AM
Could you provide some info on what this plugin does exactly? For example: how does it compare to spket?
A plugin can be anything: providing a dumb wizard, or it could offer very advanced error checking and autocompletion.

I have no idea how 'intelligent' this plugin is.

seek
29 Mar 2010, 1:26 AM
Could you provide some info on what this plugin does exactly? For example: how does it compare to spket?
A plugin can be anything: providing a dumb wizard, or it could offer very advanced error checking and autocompletion.

I have no idea how 'intelligent' this plugin is.


What can you do with this plugin? Any examples you can post here to help understand is appreciated.

Licit question!
Your response is here: http://www.extjs.com/forum/showthread.php?p=426394#post426394

HTH
Seek

roysrs
29 Mar 2010, 6:57 AM
Our content filter blocks the 3.1.1 plugin page due to some of the content (gaming/online storage). Any chance of it being hosted somewhere a little more palatable to a content filter?

seek
29 Mar 2010, 11:37 PM
Our content filter blocks the 3.1.1 plugin page due to some of the content (gaming/online storage). Any chance of it being hosted somewhere a little more palatable to a content filter?

Take a look now.

Seek

seek
6 Apr 2010, 1:48 AM
Added plugin for 3.2.0

seek
6 Apr 2010, 6:45 AM
Almost 1.000 downloads and 3 page of comments, I'm glad to know my plugin is working well!! :D

Toorp
7 Apr 2010, 12:01 AM
Almost 1.000 downloads and 3 page of comments, I'm glad to know my plugin is working well!! :D

Pre 1: English is not my native langage so excuse me if i'm not clear
Pre 2: This my first post on this forum, so let me thank Ext devlopper and community for this gret piece of software

So here is my feedback:
I noticed a strange behavior on Ubuntu 9.10:
On a base install of Aptana, your plugin works fine, but if you load PHP plugin the Ext code completion stop working :-?

To reproduce :
- Download latest Aptana
- Install it under ~ (~/bin/aptana in my case)
- Put Ext plugin in dropins
- Launch Aptana
- Create a new JS file => OK Ext plugin works and code completion is OK
- Now go to My Studio -> plugins and install PHP Development Tools (PDT)
- After installation is done, restart Aptana
- Ext plugin doesn't work anymore :(

I've search a solution a few day ago, but found nothing relevant ( i'm new to Aptana/Eclipse so maybe i do something wrong).

seek
7 Apr 2010, 1:38 AM
Pre 1: English is not my native langage so excuse me if i'm not clear
Pre 2: This my first post on this forum, so let me thank Ext devlopper and community for this gret piece of software

So here is my feedback:
I noticed a strange behavior on Ubuntu 9.10:
On a base install of Aptana, your plugin works fine, but if you load PHP plugin the Ext code completion stop working :-?

To reproduce :
- Download latest Aptana
- Install it under ~ (~/bin/aptana in my case)
- Put Ext plugin in dropins
- Launch Aptana
- Create a new JS file => OK Ext plugin works and code completion is OK
- Now go to My Studio -> plugins and install PHP Development Tools (PDT)
- After installation is done, restart Aptana
- Ext plugin doesn't work anymore :(

I've search a solution a few day ago, but found nothing relevant ( i'm new to Aptana/Eclipse so maybe i do something wrong).

Hi Toorp,
try to open a post on Aptana forum, the support is great

Seek

Toorp
7 Apr 2010, 4:07 AM
try to open a post on Aptana forum, the support is great
Seek

Hi Seek and thanks for the quick answer ;)

I think i've found the problem:
For unknow reason, after installing PDT, the default javascript editor change from Aptana to the default Eclipse javascript editor.

The procedure to resolve this problem :
- In Aptana goto Windows -> preference
- Then goto General -> Editor -> File Associations
- Select .js, normaly you should have "Aptana JS editor" as default. I my case, after installing PDT the default JS editor was set to "Javascript Editor" (default JS editor for Eclipse)

Ok now let's go for a coding afternoon B)

spor
14 Apr 2010, 1:42 AM
Hi.

I am using Aptana build 2.0.4 and installed the ExtJS 3.2 plugin and checked on it for code assist in the preferences. Also made sure that i open .js files with the Aptana editor and using Aptana web perspective.

However, I can't see any useful code assist when i use ctrl+space, some shows up, like Ext (strangely enough it disappears if typed the whole word "Ext"). E.g something as basic as onReady doesn't show up when I type Ext.o and so on.

Im wondering if this behaviour is how it should be?

realjax
16 Apr 2010, 4:21 AM
1 - Close Eclipse
2 - Copy the JAR file into .\eclipse\dropins\
3 - Open Eclipse and goto Window -> Preferences -> Apatana -> Editors -> JavaScript -> Code Assist
4 - You should see Ext 3.0 in the JavaScript Environments list, check the box and click OK


Doesn't show up in code assist list. Aptana only 'sees' the included 2.2 version. Even removeing this 2.2 jar ( that came with aptana) from the file system doesn't help, doing so will simple remove Ext from the code assist list.
Running Eclipse 3.4.2

jesseqiao
18 Apr 2010, 11:18 PM
great job, Thanks~

spor
20 Apr 2010, 6:40 AM
I have the exact same problem as realjax.

pixelmonkey
2 May 2010, 9:52 AM
The ExtJS 3.2 plugin works nicely in my Aptana install. Nice work!

spor
10 May 2010, 2:32 AM
I guess the plugin works, but how come basic things doesn't show up, like Ext.onReady?

imegai
1 Jun 2010, 12:03 PM
Hi, i´m a newbie in Extjs to start with, so i´ve intalled Aptana Studio 2 and followed the instructions in first post,
now how i know if what i´ve done it´s correct? is there a test (function, intellisense,property or aditional information in some corner of aptana Studio wich tells me the version of this plugin? because it shows the same v2... in the install new software window).
by the way i´ve a windows( not proud of) OS if that matter.

WaYdotNET
7 Jul 2010, 2:32 AM
hi Seek, this plugin work with Aptana Studio 3 beta ?

Many thx

and ... good work

(ottima idea questo plugin)

seek
30 Sep 2010, 3:01 AM
Hi all!!
Finally I found a free slot time to deploy plugin for 3.2.1.

Now I'm working on plugin for Aptana 3 and Eclipse...

seek
30 Sep 2010, 12:10 PM
I'm testing it ;)

Seek
(mille grazie!!)


hi Seek, this plugin work with Aptana Studio 3 beta ?

Many thx

and ... good work

(ottima idea questo plugin)

seek
13 Oct 2010, 2:09 PM
Updated with 3.2.2 and 3.3.0

Seek

Hiran
15 Oct 2010, 4:08 PM
Hi, Thanks Seek!

I need instructions on how to install the Plugin in Aptana Studio 2.0 please.
Copied the JAR file to Plugins folder.
... then?

Thanks.

seek
16 Oct 2010, 1:22 AM
Hi, Thanks Seek!

I need instructions on how to install the Plugin in Aptana Studio 2.0 please.
Copied the JAR file to Plugins folder.
... then?

Thanks.

...then try start a new Default Web Project!

Hiran
16 Oct 2010, 3:10 AM
Seek,

Done that.
I'm new to Aptana and also Ext. So not sure if I'm expecting too much :) I do not get Intellisense or any indication of incorrect syntax. When I type Ext I get a tool tip that says Ext no documentation. So I guess I'm still doing something not quite correct?

Thanks for your help. When this works it will be awesome!

seek
20 Oct 2010, 11:49 PM
Seek,

Done that.
I'm new to Aptana and also Ext. So not sure if I'm expecting too much :) I do not get Intellisense or any indication of incorrect syntax. When I type Ext I get a tool tip that says Ext no documentation. So I guess I'm still doing something not quite correct?

Thanks for your help. When this works it will be awesome!

Hi!
Try to read past messages, someone has experienced a similar problem.

Seek

swarm
21 Oct 2010, 12:30 AM
Hiran,

Try moving the JAR from Plugins directory to Dropins...

I'm using eclipse with aptana as a plugin (not standalone aptana) and needed to put it in the Dropins directory.

May help you...

charris
3 Nov 2010, 7:14 AM
Thanks seek! By the way, the 3.3.0 plugin shows up as Ext JS 3.2.1 in Aptana--looks like you have the wrong version info in plugin.xml

seek
3 Nov 2010, 10:27 AM
Thanks seek! By the way, the 3.3.0 plugin shows up as Ext JS 3.2.1 in Aptana--looks like you have the wrong version info in plugin.xml

D'oh!
A patch is coming :D, thanks for your feedback!

blueeinstein
4 Nov 2010, 5:10 AM
Hi - have tried both 3.2.1 and the 3.3.0 (which shows up as 3.2.1), but autocomplete doesn't seem to work perfectly. I get some of the stuff to suggest (Ext.Action, Ext.Ajax, etc)... but not some others like:

Ext.Date, Ext.fly("x").update

I'm using Aptana 2.0.5 for Mac. Any ideas? (I had been an eclipse/java user for years, and haven't seen this kind of issue)...

dhana
16 Nov 2010, 2:00 AM
Hi ,
Great work..!

Thanks
Dhana

dhana
26 Nov 2010, 11:01 PM
Hi ,
I recently Upgraded to Aptana studio 3.0 Beta and i could't able to Load ExtJs Plugin..! any one has similar issues and solutions for this problem..?

Thanks in advance
Regards
Dhana

LoriSun
13 Dec 2010, 6:50 AM
Download plugin for ExtJs 3.3.0 rev. 0001 from: MegaUpload - RapidShare
Above item displayed as Ext 3.2.1 in Eclipse Aptana plugin. Is it right?

chu_man_fu
17 Dec 2010, 8:43 AM
Hello,

Is it right in thinking that the plugin only works in HTML files?
I have tried it in PHP and JS files and it never Autocompletes or hints.

Thanks.

dhana
28 Dec 2010, 7:03 PM
Hi,
Netbeans is more flexible and comfortable, I had changed to Netbeans..! I am more faster, with Autocompletes..


Dhana

amarjitsingh
4 Jan 2011, 10:36 AM
I guess the plugin works, but how come basic things doesn't show up, like Ext.onReady?

I have similar issue, any suggestion?

sg707
2 Feb 2011, 9:44 AM
Better than nothing but as above posts. It's missing simple things like Ext.ns

seek
14 Apr 2011, 4:25 AM
Due to a serious system crash, I've lost all plugin's projects.... :(( :((
Maybe I have a backup, but first I must find it! :((
NTFS rulez...

Sorry

aacoro
18 May 2011, 1:44 PM
Due to a serious system crash, I've lost all plugin's projects.... :(( :((
Maybe I have a backup, but first I must find it! :((
NTFS rulez...

Sorry


And? Did you find it? Because this looks very promising! Good plugin and keep up the good job ~o)

vuquochuy
18 Jun 2011, 6:49 AM
I downloaded Aptana 3 in Ubuntu 11.04, then I got Ext plugin into Plugins but Ext didn't show in editor?

maiconschelter
16 Feb 2012, 8:23 AM
Thank you man!

alexeiberkov
19 Mar 2012, 1:24 AM
I downloaded Aptana 3 in Ubuntu 11.04, then I got Ext plugin into Plugins but Ext didn't show in editor?

As I understood Ext 3.X.X plugin for Aptana Studio (http://www.extjs.com/forum/showthread.php?t=89417) still in development

diractor
1 May 2012, 2:49 PM
hm... this does not seem to work anymore with Sencha 2.

Any ideas how to get code assist for the sencha library into Aptana Studio 3 ?