PDA

View Full Version : [OPEN-552][3.1.1] Ext.DomQuery.isXml is undefined in Adobe AIR



makana
10 Feb 2010, 4:51 AM
The ext-air package doesn't include the new ExtJS3.1.1 code for Ext.DomQuery, so the new isXml function is undefined when using ExtJS with Adobe AIR.
I fixed this and some other bugs and templates things in this post:
http://www.extjs.com/forum/showthread.php?t=91695

cmendez21
10 Feb 2010, 2:19 PM
I have checked on version 3.1.0 vs 3.1.1 and the domquery.js has many new functions that make issues on the selector function I have tested this also on AIR and there are many issues

makana
10 Feb 2010, 10:01 PM
Yes, I did the same. There is a major change at the Ext.DomQuery.select function, that causes the error.
Try the modified air adapter at the url above. Or at least the DomQuery part at top of the file, if you don't want to use all the included stuff.

cmendez21
6 Mar 2010, 4:00 AM
Yes, I did the same. There is a major change at the Ext.DomQuery.select function, that causes the error.
Try the modified air adapter at the url above. Or at least the DomQuery part at top of the file, if you don't want to use all the included stuff.

Thanks Done it and the problem was solved..!
check out this demo (http://e2cs.mm-mendez.com/demos/demo_e2cs_2x/Demo_001.html) for the widget i'm working on ;)