PDA

View Full Version : Designer running in Linux?



sydnic
2 Apr 2010, 6:36 AM
Is the ExtJS designer MS Windows specific, or is there a way to run the designer in Linux (Specifically Ubuntu)?

Syd Nicholson

BFT
2 Apr 2010, 6:42 AM
It is runnable on linux, there are published linux x32 and x64 distributions for ExtDesigner

Jamie Avins
2 Apr 2010, 8:11 AM
Windows, Linux 32, Linux 64, and Mac OSX 10.6 are currently supported. There are a few issues with the current distribution on Linux dealing with the use of linked libraries, we are releasing a update soon to statically link them which should fix the issue. We are also planning on supporting OSX 10.5.

aconran
2 Apr 2010, 10:53 AM
Specifically for Ubuntu if you are running Karmic 9.10 on 32/64 bit you should have absolutely no problem.

We will have static builds for other distributions early next week.

sydnic
5 Apr 2010, 2:09 AM
Tanks Aaron

I am indeed using Ubuntu 9.1 (Karmic).

How do I install the downloaded .bin file?

The file is not executable, does not appear to be a debian package, and - if I make it executable - has an error message stating that the character coding cannot be found.

Regards
Syd Nicholson

crasho
5 Apr 2010, 5:43 AM
Hi.

I'm using Linux Ubuntu 9.10 (Karmic Koala) 64 btis.

The instruction for install Ext Designer is:
sudo ./ExtDesigner-1.0.0-linux-x64-installer.bin

bye

sydnic
5 Apr 2010, 6:31 AM
Thanks very much, I thought I must be missing something.

Designer up and running

Regards
Syd Nicholson

ntzanos
7 Apr 2010, 12:45 AM
Hello,

I am using Debian Lenny (32 bit) and the Designer installed perfectly. The problem is that it will not start as it complains with the following:

bin/ExtDesigner.bin: /lib/i686/cmov/libc.so.6: version `GLIBC_2.9' not found (required by /opt/ExtDesigner/lib/libQtGuiExt.so.4)
bin/ExtDesigner.bin: /lib/i686/cmov/libc.so.6: version `GLIBC_2.10' not found (required by /opt/ExtDesigner/lib/libQtNetworkExt.so.4)
bin/ExtDesigner.bin: /lib/i686/cmov/libc.so.6: version `GLIBC_2.9' not found (required by /opt/ExtDesigner/lib/libQtCoreExt.so.4)

I checked the glibc version and it is glibc-2.11-1

Can someone please help?

Kind regards,

Nikos Tzanos

dorgan
7 Apr 2010, 6:07 AM
I believe the team plans on releasing a version of the designer with the static libraries, sometime early?? this week??

Once they do that you should be good to go.

whodat
22 Apr 2010, 2:48 PM
Hi.

I'm using Linux Ubuntu 9.10 (Karmic Koala) 64 btis.

The instruction for install Ext Designer is:
sudo ./ExtDesigner-1.0.0-linux-x64-installer.bin

bye

or


chmod 755 ExtDesigner-1.0.0-linux-installer.bin
./ExtDesigner-1.0.0-linux-installer.bin

timblack1
22 Apr 2010, 4:59 PM
Does the installer install & uninstall without breaking any of my other software? If not, can anyone package this as a .deb file for use on Ubuntu?

Trio87
22 Apr 2010, 5:45 PM
i have the same operating system and the same problem as ntzanos (http://www.extjs.com/forum/member.php?114141-ntzanos) but i have a dual boot...does this program work on windows?

abe.elias
27 Apr 2010, 9:00 PM
@Trio87 should work on windows and linux. We recently put out a static build have you tried that?

dorgan
28 Apr 2010, 5:37 AM
static build when?? I was under the impression you were still working out issues, as per http://www.extjs.com/forum/showthread.php?95101-OPEN-23-Ubuntu-9.04-GLIBC_2.10-not-found/page3

michaelg
3 May 2010, 1:59 PM
or


chmod 755 ExtDesigner-1.0.0-linux-installer.bin
./ExtDesigner-1.0.0-linux-installer.bin

Thanks, whodat, for supplying all the details. I use Linux, I don't program. The chmod command got the installer running for me. (Ubuntu Karmic 9.10, 32-bit)

Here's what worked for me:


Run the terminal program (Start> Accessories> Terminal)
In the Terminal window, type the following commands, hitting the [Enter] key after each:



cd <download folder>
chmod 755 ExtDesigner-1.0.0-linux-installer.bin
ExtDesigner-1.0.0-linux-installer.bin
Where <download folder> is the path to the folder where you downloaded the Ext Designer installer.


The Ext Designer installer runs. Create an ExtJS account, if you don't already have one, pick the location where you want the program and you're (or at least I was) up and running.

andrewm
4 Jun 2010, 10:51 AM
I'm have a noob moment here.

I'm using Lucid (Ubuntu 10.04) and the installer would not run for me


root@DEBIAN-DEV:/Post-Install# ls -l
total 122076
drwxr-xr-x 8 root root 4096 2010-03-09 10:48 Aptana Studio 2.0
-rw-r--r-- 1 andrew andrew 86317118 2010-03-09 15:43 Aptana_Studio_Setup_Linux_x86_2.0.4.zip
-rwxr-xr-x 1 andrew andrew 31419532 2010-06-04 14:00 ExtDesigner-1.0.1-linux-x64-installer.bin
root@DEBIAN-DEV:/Post-Install#
root@DEBIAN-DEV:/Post-Install# ./ExtDesigner-1.0.1-linux-x64-installer.bin
-su: ./ExtDesigner-1.0.1-linux-x64-installer.bin: cannot execute binary file
any thoughts

jarrednicholls
4 Jun 2010, 12:06 PM
Can you provide the output of these commands:



uname -a
ldd ExtDesigner-1.0.1-linux-x64-installer.bin
file ExtDesigner-1.0.1-linux-x64-installer.bin
md5sum ExtDesigner-1.0.1-linux-x64-installer.bin


The file size is correct, and its MD5 checksum is 2574336441c360c722e0f5f8a57bf60a

Have you tried the 32-bit installer?

Thanks.

wilzdezign
27 Jan 2012, 3:18 PM
Thought it would have been simple .bin or .deb files, but just downloaded the latest for Linux under the 32/64, and they are both .run files!?

Do I still install via command sudo sh ExtDesigner-1.2.2-48-x64.run

rosiebrown0
3 Feb 2012, 3:08 AM
Hey as a web designer i came to know lot of information from here...Really enjoyed it.

luiscortes
3 Feb 2012, 8:21 AM
I thought that too, but actually just set the execution bit on the file and try ./ExtDesigner-1.2.2.-48-x64.run.

How to set the execution bit:
chmod 700 ./ExtDesigner-1.2.2-48-x64.run

luiscortes
3 Feb 2012, 8:27 AM
Hi, I kind of get the feeling that KDE and Ubuntu are the required Linux distro, but ArchBang is FAST. I got ExtDesigner to install and run just through a normal install. When I run it, I get past the registration window and to the next one that asks if I want to open a project or template.

When I select any option it goes away and then just hangs (doesn't crash, just doesn't come up with the next series of windows). I am wondering if it is expecting a specific browser to be installed or a file/directory to be in a certain place. It definitely looks like it would run correctly. I am just hoping that this might be a simple tweek that someone might have run across.

aconran
3 Feb 2012, 7:20 PM
Running ArchBang Linux

Sorry, this is not on our list of supported linux distributions. I hope that someone here may be able to help you out.

luiscortes
6 Feb 2012, 10:28 AM
I knew it was a long shot, not a real issue. Just one note, I did download SenchaDesigner preview, and it does run on ArchBang without a problem. At this point, it maybe a simple matter of some library dependency is too new for ExtDesigner on my version of Linux.

FYI: I am really enjoying the new designer, great job guys!

aconran
6 Feb 2012, 1:24 PM
I did download SenchaDesigner preview, and it does run on ArchBang without a problem.
....
FYI: I am really enjoying the new designer, great job guys!

Glad you got it up and running. Thanks from the team!