PDA

View Full Version : Application works in ExtDesigner but not in any browser



treadmill
20 Apr 2010, 2:21 AM
Hi ExtJS,

I've recently built a "work in progress" interface for an online booking system.

Here is the interface I'm referring to. However, this does not load, but it loads quite happily in the ExtDesigner preview window, mind you, I don't know whether the preview is meant to load any Data Stores?

When I export the project, as is, without any changes to the files, the application simply doesn't show, but I get the following error:-

Error: this.layout.setActiveItem is not a function
Source File: http://extjs.cachefly.net/ext-3.2.0/ext-all-debug.js
Line: 18812

Here's the app, I'm referring to:-

http://dev.booking.five-star-systems.co.uk:89/Online-Booking/xds_index.html

I've also paid for a licence, so I would really appreciate help on this, as this is for a project I need to delivery asap.

I've also attached ExtDesigner project. There are some oddities with ExtDesigner not always showing correctly rendered tabs, etc. Perhaps this is a bug?

Many thanks,
Kevin

treadmill
20 Apr 2010, 4:23 AM
Ok, worked out what it was, by creating a simple ExtDesigner project. I didn't give all of my components id's.

You can close this particular thread if required. The files are still available. The link to the application URL is still active, if anyone wants to see it actually working! lol

aconran
20 Apr 2010, 11:30 AM
Great to hear that you got it up and running :)

Feel free to post here with any issues that you may encounter when working with the designer.