Class extend upgrade from 1.1.1 to 2.3.0

Printable View