Search Type: Posts; User: MrBeef

Page 1 of 2 1 2

Search: Search took 0.01 seconds.

  1. There are some others having problems with filtering, see this thread:

    http://www.sencha.com/forum/showthread.php?198865-ST-2.0.1-Ext.util.Filter-with-filterFn-not-working

    It looks like the fix...
  2. Hi all,

    Has anyone else tried filtering in the new 2.0.1.1 release yet?

    Mine is still not working and any filter I apply empties the store completely, just like 2.0.1...



    store.filter(
    {
  3. Replies
    5
    Views
    1,679
    Hi everyone,

    Just wondering if anyone else has come across this issue:

    When I load my Ext.data.Store, I loop through and add a map marker for each item. I then set a property in each store item...
  4. So I tried and it didn't work, but it's a known bug in ST 2.0.1:

    http://www.sencha.com/forum/showthread.php?198865-ST-2.0.1-Ext.util.Filter-with-filterFn-not-working
  5. Thanks! That will work - I saw that in the documentation but was wondering if I could just call the filter function twice.

    Also, I worked in Belgium for 6 months last year - had a great time there.
  6. Hi everyone,

    I want to set up a filter that works like the following:

    store.filter("TYPE",1);
    store.filter("TYPE",3);

    I would like to show all the records where the TYPE field is either 1...
  7. It took some major digging -- but it seems like adding this to the cache manifest file does the trick (allows the browser to go to the network for any non-cached resources):



    NETWORK:
    *
  8. Hi everyone,

    I have a Sencha Touch 2 app that's working fine. It has a login screen, then a few Ajax calls occur to load data within the app.

    When I add a cache manifest file into the mix (see...
  9. REQUIRED INFORMATION

    Sencha Touch version tested:

    Sencha Touch 2.0.1

    Browser versions tested against:

    Chrome
    Android 2.3.4 default browser
  10. Thanks, that helps!
  11. I worked around the problem by putting my "add" function inside of the AJAX call...but I'd still be interested in learning why the first way didn't work.
  12. Hi everyone,

    I'm using an Ext.Ajax.request to dynamically load the 'selectfield' options on an Ext.form.Panel.

    I realized that declaring variables inside of the AJAX request would not work due...
  13. That works! I guess it must be a variable scope issue.
  14. Hi all,

    I'm trying to place a link in a Google Maps InfoWindow that, when clicked, performs a function in Sencha Touch. Specifically, when clicked, I want to switch to another tab and populate a...
  15. Adding the listener inside maprender worked great, if that's where you were suggesting to put it. I didn't have to bother with the "isLoading". Thanks for the help!
  16. I want to add some markers to a Google map. The latitude and longitude are in an Ext.data.Store that is set up and working.

    I'm trying to use the following code in the map's "maprender" event, but...
  17. I answered my own question -- turns out I needed to add my Ext.TitleBar to my Ext.TabPanel.

    What I was doing before was adding the Ext.TitleBar directly to the Viewport. This was causing the form...
  18. Hi all,

    I'm using ST2, RC2. I have a form + fieldset in my application with a few 'selectfield' items. When I click them on my PC in Chrome, they open fine and I can choose the option I want.
    ...
  19. Replies
    7
    Views
    1,762
    FYI the code in this thread resolved my issue:

    http://www.sencha.com/forum/showthread.php?182895-Performance-on-refreshing-List-view-dramatically-worse-in-RC-than-Beta-3
  20. Replies
    7
    Views
    1,762
    I'm using RC2
  21. Replies
    7
    Views
    1,762
    Thanks for the replies, I'll look into using the lazy list a little later. It just strikes me that performance is slow, 195 doesn't seem to be a huge list, but maybe it is by Sencha Touch standards....
  22. Replies
    7
    Views
    1,762
    I'm loading an Ext.List with 195 items via JSON.

    On my computer, my browser locks up for maybe about 3 seconds, then works fine.

    On the Android, however, the browser locks up for 10+ seconds...
  23. Replies
    4
    Views
    1,428
    It was not, after all, I was sending just plain JSON. Thanks, I've now learned the difference between JSON and JSONP...changed the type property to 'ajax' and I'm off and running.

    Thanks again...
  24. Replies
    4
    Views
    1,428
    Thanks for the reply, did not know that about ST2. I tried the new code but I'm still having an issue. I get the "Loading..." spinner for several seconds (15 or so) then a blank screen.

    The PHP...
  25. Replies
    4
    Views
    1,428
    Any mistakes in the following code? I've been trying again and again but my JSON load doesn't work...I just see "Loading..." for several seconds then just a blank screen. I've tried loading via AJAX...
Results 1 to 25 of 26
Page 1 of 2 1 2