It is very frustrating to spend some time trying to follow the guide only to discover that it no longer works. Either put a warning that it doesn't work with 4.2+, or preferably update it.Thank you