Search Type: Posts; User: Qube

Page 1 of 2 1 2

Search: Search took 0.02 seconds.

  1. Thank you. Look forward to EXTJS-14769 in 5.0.2.
  2. Fiddle:
    https://fiddle.sencha.com/#fiddle/99f


    Ext version tested:

    Ext JS 5.0.1.1255

    Browser versions tested against:
  3. Thanks for fixing in EXTJS-14170! I'll keep an eye out for 5.0.1. The workaround above was a false positive (or true negative?). Sorry about the confusion. For posterity, I'll update the fiddle...
  4. Edit: This workaround doesn't actually work. See next post.

    This can actually be worked around by using an object config rather than a string in the proxy class. So instead of:



    reader:...
  5. Replies
    4
    Views
    648
    OK, much better solution now. That independent boot module I was asking for actually already exists in:


    /.sencha/package/Boot.js


    I wasn't sure about using files from the .sencha folder, but...
  6. Replies
    4
    Views
    648
    I figured out a workaround for this, but had to break one of the cardinal rules to do it - I had to mess with the Ext source directory.

    I did the following:

    Made a copy of bootstrap-files.js...
  7. Replies
    4
    Views
    648
    I guess the point is that it doesn't seem possible to run Ext 5 apps from the file system in Webkit browsers like we could with previous versions. This is a concern for unit test runners that...
  8. Ext version tested:

    Ext 5.0 rev 970

    Browser versions tested against:

    Chrome 35.0.1916.153 m

    DOCTYPE tested against:
  9. Ext version tested:

    Ext 5.0 rev 970
    Sencha Cmd 5.0 rev 160

    Browser versions tested against:

    Chrome 35.0.1916.153 m

    DOCTYPE tested against:
  10. Replies
    6
    Views
    2,176
    Is uglify implemented in Sencha Cmd 5? I notice the config stub is still there...
  11. It's possible to write a strict compliant version of callParent and callSuper (and Ext.Error.raise), but it requires functions to have a local name so stack crawling isn't necessary. So the signature...
  12. If you're only a few days in, I highly recommend jumping on the v5 boat, or at least using the latest Sencha Cmd. With the way Sencha Cmd works now, all of Ext, referenced packages and your own app...
  13. Replies
    5
    Views
    1,812
    If you want all buttons in a toolbar to have standard (non toolbar) styling, you can use the defaultButtonUI config. Something like this:


    tbar: {
    defaultButtonUI: 'default',

    items: [...
  14. I was really inspired by Jacky's "Making Sencha Frameworks a Piece of Cake" presentation. Wish I'd seen it live (I unwisely went to the theming session instead), but caught up via the video anyway....
  15. Replies
    6
    Views
    2,176
    Thanks for the info!

    Do you know if / when the uglify option will be wired up in Sencha Cmd? (it currently throws "Not Yet Implemented")
  16. Replies
    6
    Views
    2,176
    I'd like to add a vote for this feature. There is currently no way to tell closure to keep the "use strict" pragma when compressing with Sencha Cmd (yui has no such switch).

    Is there a way to...
  17. Log in to support.sencha.com.
    Download Ext 4.2.1 from May 22
    Extract ext.js from zip
    Examine contents

    Notice that all uses of Ext.define appear to be replaced with Ext.cmd.derive, which...
  18. This is a pretty significant change for a revision!

    I'm having exactly the same issue as the op. My answer to your question is no - we don't use Sencha Cmd at all.
  19. New version is now available. Check out Ext Spec 1.2.0 on the Sencha Market or the CodePlex site.
  20. Version 1.1.0 has just been released, so I've updated the original post to match.

    Check it out on the Sencha Market or the CodePlex site.
  21. It does "work", but I'm not sure I'd say it works well in VS2010. Using your exact example with 4.1.0, the intellisense service starts falling over at about line 8,000. There is no autocomplete for...
  22. OK, fair enough. Documenting it sounds like the right course.

    Just for some context, the reason I picked it up is that I work with a fairly large dev team of varying skill levels (at least with...
  23. REQUIRED INFORMATION

    Ext version tested:

    Ext 4.1.3

    Browser versions tested against:

    Chrome
  24. The JavaScript interpreter in VS2010 is a bit shaky. It's the same one used in WSH and older IE. I've found it falls over a short way into parsing the Ext library.

    I know this doesn't solve your...
  25. Finally got this thing to 1.0!

    It now comes with a JSDoc distribution that should be compatible with JSDuck or ScriptDoc. I tested it with Aptana, and the autocomplete and parameter help seemed to...
Results 1 to 25 of 29
Page 1 of 2 1 2