Search Type: Posts; User: Max_nl

Page 1 of 2 1 2

Search: Search took 0.04 seconds.

  1. Replies
    578
    Views
    96,126
    Don't like the changes either.

    Probably switch over to the GPL licensed version.
    Don't mind including the Javascript source with our software that much, obfuscation is overrated anyway.
  2. Replies
    46
    Views
    96,072
    That repo was last updated August 22 2013, and doesn't have Ext.JS 5.
  3. Replies
    46
    Views
    96,072
    You are probably talking about the commercial license, or one of the license exemptions for software under a different license than GPL...

    There is no such line in the GPL version available at:...
  4. Replies
    46
    Views
    96,072
    And why exactly would it be a violation to distribute the GPL version?
  5. Worse in what way exactly?
    I never found number of Google search results saying such or so a convincing argument in technical discussions.
  6. That is about most Ext.Direct implementations being vulnerable to CSRF attacks by default.

    - You are logged in as admin to a typical web application which uses Ext.JS for the frontend, PHP as...
  7. ????

    Note that when I mention HTML encoding it is about converting < to &lt; when displaying plain-text data. Something that does not happen in Ext.JS components like grids by default, and is a...
  8. Vulnerability

    This backend -like probably all other Ext.Direct implementations- is vulnerable to Cross-Site Request Forgery attacks.
    If an attacker is able to trick a user that is currently...
  9. Was wondering if any effort is being done to help improve the security of Ext.js applications.
    Even though Sencha seemed to start using "security" as a selling point for other products like Space,...
  10. Can see the benefits of being able to disable it if you already have HTML formatted rich text serverwide that you specifically want to be displayed that way.




    However recall that blindly...
  11. +1

    It would be very nice if Sencha would use the opportunity to enable HTML escaping by default in version 5. And not just for the new data binding, but everywhere else as well, e.g. htmlEncode...
  12. Correct.
    (but I cannot rely on Referer checking, if that is what you are aiming at.)
  13. I was wondering if there is any easy way to instruct the Ext.Direct code to always send an extra parameter (nonce token) with all calls to the server?


    I'm a bit concerned about the potential...
  14. If an Ext.Direct script returns invalid non-json output (for example: due to php warnings), Ext always displays the message "Error parsing json response: null"

    This is caused by the function:

    ...
  15. Replies
    58
    Views
    42,110
    Ayone tried to port this one to Ext.js 4 yet?


    Got to the point where it throws a nice long stack trace on calling the show( ) method. :(



    el is null
    onRender(container=Object {...
  16. Replies
    0
    Views
    2,411
    I have the problem that scrolling Lists does not work on a HTC Desire (Android 2.2) when the "viewport" meta tag is present (even with only: <meta name="viewport" content="">)
    I tried setting...
  17. Replies
    190
    Views
    171,606
    One of my earlier projects.
    NOC-PS is a software package for dedicated server hosting providers, that automates the installation of operating systems over the network.
    ...
  18. Probably caused by the KDE QT plug-ins as well, I suspect they alter the look-and-file of those dialogs.
    Would explain why it works for you, as Ubuntu uses Gnome, and Kubuntu KDE.
  19. Found a workaround for Kubuntu 10.04 64-bit:

    - Open ~/.config/Trolltech.conf in a text editor.
    - Remove or comment out the following line:



    Only works until the next reboot, after which...
  20. Any update on the static build?




    On one of my Kubuntu 10.04 64-bit computers it indeed does start when you download the 32-bit version.
    But the moment you try to save anything it crashes....
  21. Related to: http://www.extjs.com/forum/showthread.php?p=452225#post452225
  22. One more issue guys.
    If I add layoutOnTabChange like suggested, it works fine in Firefox and Chrome, but still breaks when using IE8.



    Webpage error details

    User Agent: Mozilla/4.0...
  23. My web application works fine with Ext.js 3.1.1.
    With 3.2RC1 it does work properly with Firefox and Chrome, but not under Internet Explorer 8.


    Under IE8, I get the following error message:

    ...
  24. Thanks.
    Saves only 0.3 sec, but all small bits help.
  25. Already had a DOCTYPE, and changing it doesn't seem to help.

    e.g. I'm using a two page cardlayout based wizard somewhere, that has a lot of checkboxes in it, and it takes 4.5 seconds to render on...
Results 1 to 25 of 46
Page 1 of 2 1 2