I've inherited an ExtJS app written against 3.x, and tried to load it with 4.0.1 and the compatibility layer. (The code was written by a contractor, using his license, so when we bought one naturally...