you need to update api and use proper api show me api i can give u idea