Search Type: Posts; User: goatkarma

Page 1 of 2 1 2

Search: Search took 0.03 seconds.

  1. So as is often the case, after scratching my head for hours, I fix it 20mins after posting here!

    I needed to give the detailCard an xtype:panel (or whatever you want for it), and set...
  2. I've successfully managed to load in my JSON for a nested list, with the final leaf being tappable to display Details Card.

    The problem I am having is that the details card is clipping data, or...
  3. 1. I used a proxy PHP script on the same server as the webapp that accepted the requests, went off and got the data required from elsewhere, then formatted it and returned it back to the app. This...
  4. Incidentally, does anyone know why that happens? I've even tried moving the URL down to below the 'type' attribute, but it still just bounces back to being above the proxy setting once the app is...
  5. Found the problem. Thought it was a typo I've just been missing, but it appears the build process moves the proxy URL from within the proxy brackets, to above it. Weird. Anyway, just need to remember...
  6. My app works fine in development, and builds fine using 'sencha app build testing' (or production). The problem is when i upload the app to our web server I get the above error. It seems to be on...
  7. Your PHP file needs to output the correct content type for the image type you are using, so if it's a gif you would have something like this in your index.php file:


    <? header ("Content-Type:...
  8. Ok, so afte some googling, it appears native apps use the file:// protocol rather than HTTP so AJAX cross domain issues will not occur. I guess that means as long as I put the full URL of the proxy...
  9. Slowly getting towards having a production webapp and now turning attention to making the app native.
    One thing I'm not so sure on is our proxy/gateway script. I have a PHP script that acts as a...
  10. Any sign of this fix being in the next release? I did a quick search for 'Touch-4269' in the Release Notes but couldn't see it mentioned.
  11. I'm an id!ot ! I probably don't need two controllers exactly! I just set the new URL for the store on the previous item tap event, then load the store once the new view is shown!

    So I just had...
  12. Having a wee bit of difficulty with this, really hope someone can help!

    Basically, I have a List which is populated by a JSON file in a store. The JSON file consists of just titles and links. ...
  13. Ah ha...just found this:

    http://www.sencha.com/forum/showthread.php?260445-maprender-event-s-2nd-argument-is-undefined
  14. No errors in the console at all, although the console.log for 'map' after it is passed into the function at 'maprender' is undefined which is interesting, and probably the problem!

    The map loads...
  15. This solved it, apart from a few styling issues!


    http://senchatouchexp.blogspot.co.uk/2012/12/sencha-touch-20x-upgrade-21.html
  16. I think I must've set up my original app (which still isnt production) ages ago, but just started working on it again recently.

    What steps do I need to take to upgrade it to 2.1? I've installed...
  17. Replies
    2
    Views
    306
    It looks like badgeCls only works on buttons with badges, rather than tabs. So....

    A guy on stackoverflow helped, and created the below 'onItemAdd' function when creating a tabpanel. Seemed to do...
  18. Hi Mitchell, think I was wording my question pretty badly, so started a new thread here which has since been fixed, thanks!
    ...
  19. Replies
    2
    Views
    306
    I've knocked up a quick test in jsfiddle to simplify everything right down, and it still doesn't work?
    http://jsfiddle.net/goatkarma/vv66Z/11/


    Having played around a bit more, it appears that...
  20. Replies
    2
    Views
    306
    Hopefully this is a quickie, and probably something pretty obvious I'm missing! For some reason I can't get badgeCls to work. There's a few questions around about how to replace the badgeCls 'on...
  21. Many thanks Enno! That pretty much did the trick. It's a wee bit clunky (you can visibly see the icon being removed at the end of the slide animation), but I think a delay task should fix that...
  22. Am i on the right track with this, or is it a pretty clumsy way of doing it?

    I have my 'main' tab panel, which i've added all the items, setting the accountmenu to hidden (i.e the one you see when...
  23. Ok, so perhaps another way to do it would be to have the 'me' tab go straight to the 'accountmenu' navigation view, and do a check there to see if logged in or not. If logged in, show the navigation...
  24. I asked the wrong question earlier, and I can't seem to delete the thread so thought I'd start a new one with screenshots:)


    My 'main' is a tabpanel consisting of three tabs. One of these tabs...
  25. *skip to bottom for question, moved on a wee bit**

    I've got a login form in a panel, that once someone has successfully has logged in, should load a navigation view with an xtype: 'accountmenu'.
    ...
Results 1 to 25 of 32
Page 1 of 2 1 2