function getcharts(){
Ext.application({
requires:
['Ext.chart.*',
'Ext.Window', 'Ext.fx.target.Sprite', 'Ext.layout.container.Fit', 'Ext.window.MessageBox']
,
...