1. #1
    Ext User peanutmedia's Avatar
    Join Date
    May 2010
    Location
    Leeds, United Kingdom
    Posts
    13
    Vote Rating
    0
    peanutmedia is on a distinguished road

      0  

    Default Empty GUI on Lenny

    Empty GUI on Lenny


    Hello,

    I'm sorry, I didn't want to post this into bugs as it might be the simple case of me missing something, perhaps a dependency or just a setting...

    The problem I'm having is, under Debian Lenny the Designer doesn't display any of the GUI elements (canvas, toolbox, the component tree and the configuration grid), when it starts up it only gives me an empty grey screen with the Ext logo on it (the same that displays under Windows before the GUI is loaded).

    This problem has been present since 1.0.2, 1.0.1 is running fine.

    Any help would be greatly appreciated,

    Thanks,
    Andy Pasztirak, Peanut Media

  2. #2
    Sencha - Desktop Packager Dev Team jarrednicholls's Avatar
    Join Date
    Mar 2007
    Location
    Frederick, MD
    Posts
    1,747
    Vote Rating
    7
    jarrednicholls will become famous soon enough jarrednicholls will become famous soon enough

      0  

    Default


    That is most bizarre Andy. Perhaps if you try following these steps, incase the application didn't automatically update to the latest version: http://www.sencha.com/forum/showthre...o-xds-1.0.2.14

    Let me know if that straightens it out. If not we'll take the next step.

  3. #3
    Ext User peanutmedia's Avatar
    Join Date
    May 2010
    Location
    Leeds, United Kingdom
    Posts
    13
    Vote Rating
    0
    peanutmedia is on a distinguished road

      0  

    Default


    Quote Originally Posted by jarrednicholls View Post
    That is most bizarre Andy. Perhaps if you try following these steps, incase the application didn't automatically update to the latest version: http://www.sencha.com/forum/showthre...o-xds-1.0.2.14

    Let me know if that straightens it out. If not we'll take the next step.
    Hi Jarred,

    This is actually a freshly downloaded installer (from yesterday), I checked the ini file and the xds-1.0.2.14.ion in the config folder, all seems to be in order there. I would love to provide a more verbose debug information but unfortunately I get no error messages from the terminal at all.

    I would appreciate your help on this!

    Cheers,
    Andy

  4. #4
    Ext User peanutmedia's Avatar
    Join Date
    May 2010
    Location
    Leeds, United Kingdom
    Posts
    13
    Vote Rating
    0
    peanutmedia is on a distinguished road

      0  

    Default


    Hey Jarred,

    Is there any news on this - or is there something I can help with in terms of debugging the problem? It's a pretty serious one for me as every time I want to use the designer I have to start Windows but I'm doing most of my work in Linux, which makes the coding a bit tedious!

    Thanks,
    Andy
    Andy Pasztirak
    Peanut Media

  5. #5
    Ext User peanutmedia's Avatar
    Join Date
    May 2010
    Location
    Leeds, United Kingdom
    Posts
    13
    Vote Rating
    0
    peanutmedia is on a distinguished road

      0  

    Default


    I have to apologise for the number of posts I'm making here but I want to keep this thread up to date... I found that if I start the designer without parameters it will display the default background (as described above the ExtJS logo) after trying to start a new project.

    However, if I try to open an existing project (./ExtDesigner ~/extproject/admin-interface.xds) and then start a new project from the menu then it works perfectly fine. I hope this will be of some help for anyone investigating this issue!

    Cheers,
    Andy

  6. #6
    Sencha - Desktop Packager Dev Team jarrednicholls's Avatar
    Join Date
    Mar 2007
    Location
    Frederick, MD
    Posts
    1,747
    Vote Rating
    7
    jarrednicholls will become famous soon enough jarrednicholls will become famous soon enough

      0  

    Default


    Hey Andy,

    Try deleting all files in the following folders:
    1. ~/.local/share/data/Ext JS, Inc./Ext Designer/
    2. ~/.config/Ext JS, Inc./

    Then, launch the Designer. Re-authenticate, and then It will say an update is available...go ahead and install that. Afterwards, do you have any better luck? I'm thinking perhaps something is corrupt in the LocalStorage of the application, i.e., something in the "Recent Projects" list that is bad. Not too sure. As of now, nothing is wrong with your installation because you are getting the shell to launch. Beyond the shell launching, it is either an error in localstorage or a javascript error. Since this issue isn't occurring with anyone else's installation, it's not a javascript error :-)

    Let me know.

  7. #7
    Ext User peanutmedia's Avatar
    Join Date
    May 2010
    Location
    Leeds, United Kingdom
    Posts
    13
    Vote Rating
    0
    peanutmedia is on a distinguished road

      0  

    Default


    Hey Jarred,

    Thanks for the advice, I tried it last night, unfortunately it produced the same results after removing the files in the directories above.

    I have also tried removing said directories completely, and Ext Designer, and reinstalling from scratch but I had no luck with it, same things happen. Authentication works fine, I get to the welcome window where I can pick whether I want a new project or an old one (I guess because I had no project saved in it, but the only option that actually shows is the new project one), then as soon as I click the new project button I'm given the grey background with the Ext logo.

    Loading an existing project still works fine, and I can start a new one from there, so it's a strange thing to happen!
    Andy Pasztirak
    Peanut Media

  8. #8
    Sencha - Desktop Packager Dev Team jarrednicholls's Avatar
    Join Date
    Mar 2007
    Location
    Frederick, MD
    Posts
    1,747
    Vote Rating
    7
    jarrednicholls will become famous soon enough jarrednicholls will become famous soon enough

      0  

    Default


    Are you running Gnome or KDE?

  9. #9
    Ext User peanutmedia's Avatar
    Join Date
    May 2010
    Location
    Leeds, United Kingdom
    Posts
    13
    Vote Rating
    0
    peanutmedia is on a distinguished road

      0  

    Default


    It's ratpoison, sorry, should have mentioned that earlier. I will give it a go on GNOME a bit later and will let you know how it went!
    Andy Pasztirak
    Peanut Media

  10. #10
    Sencha - Desktop Packager Dev Team jarrednicholls's Avatar
    Join Date
    Mar 2007
    Location
    Frederick, MD
    Posts
    1,747
    Vote Rating
    7
    jarrednicholls will become famous soon enough jarrednicholls will become famous soon enough

      0  

    Default


    Ok sounds good. I've tried it using awesome and it didn't work out so well. Qt is built against X11 and technically should work fine, but there may be some issues there. From a technical standpoint, it *should* work fine...albeit you will need that mouse, unfortunately ;-)

Similar Threads

  1. Replies: 3
    Last Post: 11 Aug 2009, 12:36 AM
  2. Replies: 5
    Last Post: 21 Jul 2009, 8:52 PM
  3. Replies: 10
    Last Post: 20 Jun 2009, 6:08 AM
  4. PagingToolbar not showing empty message when store is empty
    By bledford in forum Ext 2.x: Help & Discussion
    Replies: 5
    Last Post: 18 Mar 2008, 7:51 AM

Thread Participants: 1

Tags for this Thread