1. #1
    Ext User
    Join Date
    Oct 2010
    Posts
    1
    Vote Rating
    0
    c.prerovsky is on a distinguished road

      0  

    Question Unanswered: z-index problem with TabPanel & Flash

    Unanswered: z-index problem with TabPanel & Flash


    Hi guys,

    first of all: I know that this is not a extJS-related problem - it's browser specific, and occurs only with Chrome and Safari.

    While developing Aloha Editor (http://www.aloha-editor.com/) we're stuck with flash videos from youtube: we use a TabPanel for our FloatingMenu, which will keep close to the block element you're editing. However, embedding an SWF object will cause the TabPanel to vanish behind the objects - it seems that z-indexes are completely ignored.

    After googling for a while I've tried setting the SWF's position CSS attribute to 'relative' to be able to set a z-index, as well as setting it's wmode param to 'opaque' or 'transparent' - nothing works for me. IE and FF handle the z-index fine (without any modifications).

    Any ideas?
    Thank you!
    Clemens

  2. #2
    Touch Premium Member
    Join Date
    Jun 2008
    Posts
    37
    Vote Rating
    0
    pflammer is on a distinguished road

      0  

    Default wmode should be opaque

    wmode should be opaque


    Flash doesn't respect things like z-index. In order to get this to work, you have to directly instruct it to. This is done using the wmode attribute. You can see one solution here when loading youtube videos:
    http://www.eliacom.com/esp/help.php?help

    The code you'll need to use looks something like this for youtube embedding. If you are directly embedding the swf, then you need to put in a wmode parameter into the embed or object tag (I can't remember which):
    HTML Code:
    <iframe width="560" height="315" src="http://www.youtube.com/embed/OFqVx378_pI?wmode=opaque" frameborder="0" allowfullscreen>

Similar Threads

  1. deselectRow(index) & getSelectionModel() index
    By iBeb in forum Ext 2.x: Help & Discussion
    Replies: 1
    Last Post: 17 Feb 2010, 9:21 AM
  2. flash z-index problem
    By hicker in forum Ext 1.x: Help & Discussion
    Replies: 5
    Last Post: 23 Aug 2009, 5:00 AM
  3. ExtJS & Flash - problem with ext window
    By zeroed in forum Ext 2.x: Help & Discussion
    Replies: 2
    Last Post: 30 Jun 2009, 5:10 AM
  4. Flash & Z-Order
    By Lloyd K in forum Ext 2.x: Help & Discussion
    Replies: 5
    Last Post: 7 Nov 2007, 1:16 AM
  5. EXT 1.1Beta1 Flash Z-index + toolbar menu funky issue
    By jay@moduscreate.com in forum Ext 1.x: Help & Discussion
    Replies: 1
    Last Post: 13 Jun 2007, 3:28 PM

Thread Participants: 1