1. #1
    Sencha User
    Join Date
    Oct 2007
    Posts
    447
    Vote Rating
    0
    mxu is on a distinguished road

      0  

    Exclamation ExtJS 2.* or ExtJS3.*

    ExtJS 2.* or ExtJS3.*


    hello,

    I mimic standalone app for a web app using ExtJS 2.* over a couple of year backs, . see the link
    http://www.ncbi.nlm.nih.gov/projects...1&to=191000001
    but unfortunately the codes broke when I linked to ExtJS3.* js libs.
    I can stay with ExtJS2.2 for now but how long will ExtJS2.2 last ? the 2.2 will get update for new version of FF. IE, etc ?

    thanks

    mxu

  2. #2
    Sencha - Community Support Team Condor's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    24,246
    Vote Rating
    83
    Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of

      0  

    Default


    No, the whole Ext 2.x branch is EOL.

    Upgrading to 2.3 will give you Firefox 3 support, but I would really recommend upgrading to 3.x.

    Did you read the Upgrading to Ext 3 thread?

  3. #3
    Sencha User
    Join Date
    Oct 2007
    Posts
    447
    Vote Rating
    0
    mxu is on a distinguished road

      0  

    Default


    tried to migrate to v3.* but the app totally broke at core js libs
    js libs included in order as below are
    ...
    <script type="text/javascript" src="/core/extjs/ext-3.2.1/adapter/ext/ext-base-debug.js"></script>
    <script type="text/javascript" src="/core/extjs/ext-3.2.1/ext-all-debug.js"></script>
    ...

    at the page initial loading,
    Firebug stopped at var o = this.getConnectionObject(); for sync ajax call
    complaining getConnectionObject() undefiend
    when I commented out the sync ajax and Firebug stopped at Ext.Fly(ce), line#9808 at ext-all-debug.js
    9806 if (this.contentEl){
    9807 var ce = Ext.getDom(this.contentEl);
    9808 Ext.fly(ce).removeClass(['x-hidden', 'x-hide-display']);
    9809 contentTarget.appendChild(ce);
    9810 }

    are page loading different between V2.2 and v3.* ?

    thanks

    ming

  4. #4
    Sencha - Community Support Team Condor's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    24,246
    Vote Rating
    83
    Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of

      0  

    Default


    You want to make synchronous Ajax calls?

    Are you using a user extension for that (e.g. ext-basex)? You will need to upgrade all extensions to Ext 3 compatible versions too.

  5. #5
    Sencha User
    Join Date
    Oct 2007
    Posts
    447
    Vote Rating
    0
    mxu is on a distinguished road

      0  

    Default


    yes, I need sync call for genome info to populate individual tracks.
    I coded the page over two years and used many user modified/extension, it's ok to migrate to 2.3.0 but not 3.*.
    for sure I am going to get a few more gray hair at migrating to 3.*, or Probably wait for ExtJS 4.* as long as
    v2.3 works for current browsers.

    anyhow EXtJS is the best JS widets for web app.

    mxu

Similar Threads

  1. How to using TreeGrid in Extjs3.2.1
    By anya in forum Ext 3.x: Help & Discussion
    Replies: 11
    Last Post: 18 Mar 2012, 11:15 PM
  2. How to use Break; in extjs3.0
    By anusham in forum Ext 3.x: Help & Discussion
    Replies: 5
    Last Post: 23 Aug 2010, 2:49 PM
  3. Coldfusion 9 license and ExtJS3.1
    By kumkumbaba in forum Community Discussion
    Replies: 1
    Last Post: 15 Jan 2010, 11:49 PM
  4. Replies: 1
    Last Post: 23 Dec 2009, 3:32 PM

Thread Participants: 1