Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Ext JS Premium Member
    Join Date
    Jun 2010
    Posts
    4
    Vote Rating
    0
    ath is on a distinguished road

      0  

    Default [CLOSED] Unable to disable timeout in Ext.Ajax

    [CLOSED] Unable to disable timeout in Ext.Ajax


    We were hoping to be able to disable the timeout
    in Ext.Ajax.request by setting the timeout property
    to null. Looking at the code we can see that this
    is not possible, even though it seems that this was
    intended at some point. We have therefore concluded
    that this must be a bug.

    In ext-3.3.1:

    If you look at the handleReadyState method of
    src/adapter/ext-base-ajax.js (line 187) it checks that a
    callback has been set and if not no timeout for the
    request is set.

    In the method request in file src/data/Connection.js line 219
    the timeout is set to a number explicitly using Ext.num.

    This means that it is not possible to disable timeout of an
    Ext.Ajax request.

    Ext version tested:
    • Ext 3.3.1

    Adapter used:
    • ext

    css used:
    • only default ext-all.css



    Browser versions tested against:
    • Chrome 7

    Operating System:
    • Ubuntu

  2. #2
    Sencha - Community Support Team Condor's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    24,246
    Vote Rating
    83
    Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of Condor has much to be proud of

      0  

    Default


    This is caused by this bugfix.

    You should be using timeout:0 and not timeout:null.

  3. #3
    Ext JS Premium Member
    Join Date
    Jun 2010
    Posts
    4
    Vote Rating
    0
    ath is on a distinguished road

      0  

    Default


    Hi,

    Thamks for your quick reply! i tested it and it works like you described.

    I expected that setting the timeout to null would do the same.

  4. #4
    Sencha Premium Member
    Join Date
    Apr 2014
    Posts
    2
    Vote Rating
    0
    Kombra is on a distinguished road

      0  

    Default Setting Ajax timeout:0 is not disabling Default timeout(30 sec)

    Setting Ajax timeout:0 is not disabling Default timeout(30 sec)


    Quote Originally Posted by Condor View Post
    This is caused by this bugfix.

    You should be using timeout:0 and not timeout:null.
    Hi Condor,

    Setting Ajax timeout:0 is not disabling Default timeout(30 sec) in 4.2.2.
    Please help me out to disable default timeout. (or to set timeout to infinite)

Similar Threads

  1. how can i override the ext js ajax timeout for more than one hour?
    By rramkumar in forum Ext 3.x: Help & Discussion
    Replies: 15
    Last Post: 14 Oct 2010, 5:38 AM
  2. Does Ext.Ajax.timeout work for small values?
    By sacha in forum Ext 3.x: Help & Discussion
    Replies: 3
    Last Post: 2 Aug 2010, 11:50 PM
  3. Ext.Ajax.timeout issue
    By sriharshaparigi in forum Ext 2.x: Help & Discussion
    Replies: 1
    Last Post: 30 Mar 2010, 4:54 AM

Thread Participants: 2

Tags for this Thread