1. #1
    Ext User
    Join Date
    Apr 2008
    Posts
    14
    Vote Rating
    0
    g_papasavva is on a distinguished road

      0  

    Default help htmlEditor Chrome behaves incorrectly

    help htmlEditor Chrome behaves incorrectly


    The htmlEditor in Chrome behaves incorrectly.
    Lets say you enter the following test
    "Hello World"
    Place the cursor in front of "H" (in front of the "hello" word). Click enter.
    Two <br/> are added instead of one
    Now place the cursor at the end of "Hello World" and click enter
    Now only a single <br/> is added.

    The function fixKeys().. for htmlEditor contains the following line for chrome
    this.execCmd('InsertHtml','<br /><br />');
    Is there anyway to fix this. It should add only a single breakpoint all the times

  2. #2
    Ext User
    Join Date
    Apr 2008
    Posts
    14
    Vote Rating
    0
    g_papasavva is on a distinguished road

      0  

    Default


    The solution is the following
    Replace
    this.execCmd('InsertHtml','<br /><br />');
    with
    this.execCmd('InsertHtml','<br />&nbsp;');
    this.execCmd('Delete');

Similar Threads

  1. [OPEN-606] Select field's setValue() behaves incorrectly if value is 0.
    By elishnevsky in forum Sencha Touch 1.x: Bugs
    Replies: 1
    Last Post: 29 Nov 2010, 11:09 AM
  2. [3.2]VBox layout behaves incorrectly
    By Stju in forum Ext 3.x: Help & Discussion
    Replies: 8
    Last Post: 6 Apr 2010, 11:26 PM
  3. Form fields displaying incorrectly in IE and Chrome
    By qqzm in forum Ext 3.x: Help & Discussion
    Replies: 0
    Last Post: 26 Jan 2010, 6:40 AM
  4. Replies: 5
    Last Post: 2 Jul 2009, 1:58 PM
  5. Replies: 1
    Last Post: 12 Nov 2008, 10:14 AM