1. #1
    Ext JS Premium Member
    Join Date
    Sep 2008
    Posts
    10
    Vote Rating
    1
    extdev22 is on a distinguished road

      0  

    Default Extjs 4.0 support for IE9

    Extjs 4.0 support for IE9


    Hi, does Extjs 4.0 will fully support IE9? in other words if application developed in Extjs 4.0 and tested using IE9 is there anything expected to be broken?

    Thanks
    -->

  2. #2
    Sencha User Jaitsu's Avatar
    Join Date
    Sep 2008
    Location
    Liverpool, England
    Posts
    160
    Vote Rating
    1
    Jaitsu has a spectacular aura about Jaitsu has a spectacular aura about

      0  

    Default


    I'm gonna guess that the ExtJS team have IE9 compatibility in mind.

    But what about ExtJS 3.0 support as well? Will there be and update to 3.3 to add in IE9 support?
    -->

  3. #3
    Sencha - Sencha Touch Dev Team Jamie Avins's Avatar
    Join Date
    Mar 2007
    Location
    Redwood City, California
    Posts
    3,661
    Vote Rating
    21
    Jamie Avins is a jewel in the rough Jamie Avins is a jewel in the rough Jamie Avins is a jewel in the rough Jamie Avins is a jewel in the rough

      0  

    Default


    IE9 will be fully supported in Ext JS 4. 3.3 will get an update to make it compatible as well.
    -->

  4. #4
    Sencha User
    Join Date
    Oct 2008
    Posts
    48
    Vote Rating
    0
    Daz is on a distinguished road

      0  

    Default


    Jamie, any updates on when 3.3 will get IE9 support

    Would really help us for project planning/ client feedback.
    Thanks.
    -->

  5. #5
    Ext JS Premium Member
    Join Date
    Aug 2007
    Location
    Antwerp, Belgium
    Posts
    555
    Vote Rating
    27
    joeri has a spectacular aura about joeri has a spectacular aura about joeri has a spectacular aura about

      0  

    Default


    You don't need to wait for an Ext update to support IE9.

    What I do right now is force it back to IE8 mode with the following tag in the head section of the container page in which Ext is loaded:
    Code:
    <meta http-equiv="X-UA-Compatible" content="IE=8">
    Seems to work well enough.
    -->

  6. #6
    Sencha User
    Join Date
    Oct 2008
    Posts
    48
    Vote Rating
    0
    Daz is on a distinguished road

      0  

    Default


    Thanks for the reply - we were hoping that would work, unfortunately compatibility isn’t a solution as it's causing rendering problems (and isn’t supported because of the rendering issues it causes).

    We're also using Raphael and compatibility results in JavaScript problems for Raphael.

    Also tried having IE9 detected as IE8 but that doesn’t work with TreeNode components:
    http://www.sencha.com/forum/showthre...158#post562158

    We have consumer apps so we can’t control the browser being used and there doesn’t appear to be a viable workaround. Hence we're looking at project planning around when 3.3 will support IE9.

    Grateful for your suggestion though and would welcome any workarounds that might resolve this.
    -->

  7. #7
    Sencha User
    Join Date
    Mar 2011
    Posts
    1
    Vote Rating
    0
    anonymouse is on a distinguished road

      0  

    Default IE9 release date is 3/15

    IE9 release date is 3/15


    Now that the IE9 release date is out (3/15), what is the plan for the timing of the ext-js 3.3 compatibility update? Will that be available on 3/15 as well? If not, how long should we expect that to take?
    -->

  8. #8
    Ext JS Premium Member Munter's Avatar
    Join Date
    Dec 2009
    Location
    Copenhagen, Denmark
    Posts
    55
    Vote Rating
    0
    Munter is on a distinguished road

      0  

    Default Any news?

    Any news?


    So now IE9 is on the street.

    When can we expect an update?

    It has been awfully quiet in here for 1½ months now.
    -->

  9. #9
    Sencha User
    Join Date
    Mar 2008
    Posts
    27
    Vote Rating
    0
    oxygen is on a distinguished road

      0  

    Lightbulb ExtJS 3.3.2 not fully support IE9

    ExtJS 3.3.2 not fully support IE9


    ExtJS 3.3.2 not fully support IE9 ......
    -->

  10. #10
    Sencha User
    Join Date
    Jun 2008
    Posts
    289
    Vote Rating
    16
    Qtx will become famous soon enough

      0  

    Default


    I got now IE9 and tested my app and samples from ExtJS 3.3.1, horrible! They changed really much in IE9. By upgrading from IE7 to IE8 I had almost nothing to do, all worked fine.

    joeri, thank you very much for tip with tag!
    -->

Similar Threads

  1. [OPEN-1434] ExtJS, TreePanel and IE9
    By Tegud in forum Ext 3.x: Bugs
    Replies: 17
    Last Post: 6 Feb 2013, 3:22 AM
  2. [OPEN-1278] SCRIPT438 error with IE9 Beta and ext-all-debug.js
    By stevenwilford in forum Ext 3.x: Bugs
    Replies: 8
    Last Post: 9 Apr 2012, 7:05 AM
  3. What's going on with ie9 support?
    By Ozone in forum Community Discussion
    Replies: 11
    Last Post: 15 Sep 2010, 11:16 PM
  4. A Glimpse at IE9 (the early days)
    By hendricd in forum Community Discussion
    Replies: 13
    Last Post: 6 May 2010, 11:44 PM

Thread Participants: 19