1. #1
    Sencha User freewizard's Avatar
    Join Date
    Jan 2009
    Posts
    2
    Vote Rating
    0
    freewizard is on a distinguished road

      0  

    Question how to rebuild styles?

    how to rebuild styles?


    invoking compass gave me a few errors

    Code:
    d@FWDev-Pro sass $ gem list --local| grep compass
    compass (0.10.6)
    
    d@FWDev-Pro Documents $ cd ext-4.0-pr5/resources/sass/
    
    d@FWDev-Pro sass $ touch config.rb 
    
    d@FWDev-Pro sass $ compass compile
       exists ../css
      compile ext-all-scoped.scss
        error ext-all-scoped.scss (Line 1: Invalid CSS after "@function min(": expected ")", was "$value1, $value...")
    overwrite ../css/ext-all-scoped.css
      compile ext-all.scss
        error ext-all.scss (Line 1: Invalid CSS after "@function min(": expected ")", was "$value1, $value...")
    overwrite ../css/ext-all.css
      compile ext-ie-scoped.scss
        error ext-ie-scoped.scss (Line 1: Invalid CSS after "@function min(": expected ")", was "$value1, $value...")
    overwrite ../css/ext-ie-scoped.css
      compile ext-ie.scss
        error ext-ie.scss (Line 1: Invalid CSS after "@function min(": expected ")", was "$value1, $value...")
    overwrite ../css/ext-ie.css
      compile ext-sandbox.scss
        error ext-sandbox.scss (Line 1: Invalid CSS after "@function min(": expected ")", was "$value1, $value...")
    overwrite ../css/ext-sandbox.css
      compile ext-standard-scoped.scss
        error ext-standard-scoped.scss (Line 1: Invalid CSS after "@function min(": expected ")", was "$value1, $value...")
    overwrite ../css/ext-standard-scoped.css
      compile ext-standard.scss
        error ext-standard.scss (Line 1: Invalid CSS after "@function min(": expected ")", was "$value1, $value...")
    overwrite ../css/ext-standard.css

  2. #2
    Sencha Premium Member vadimv's Avatar
    Join Date
    Sep 2010
    Location
    Chisinau, Moldova
    Posts
    642
    Vote Rating
    25
    vadimv will become famous soon enough vadimv will become famous soon enough

      0  

    Default


    yeap, the same to me... looking for solution

  3. #3
    Ext JS Premium Member westy's Avatar
    Join Date
    Feb 2009
    Location
    Bath, UK
    Posts
    941
    Vote Rating
    64
    westy is just really nice westy is just really nice westy is just really nice westy is just really nice

      0  

    Default


    I believe you need to use the pre-release versions of compass and sass.

    When I run gem list I get:
    Code:
    *** LOCAL GEMS ***
    
    chunky_png (0.12.0)
    compass (0.11.beta.2, 0.10.6)
    haml (3.0.25)
    minitest (1.6.0)
    rake (0.8.7)
    rdoc (2.5.8)
    sass (3.1.0.alpha.221)
    I seem to remember a post about how to do it early on... was something like -pre on the gem install command.

  4. #4
    Sencha Premium Member vadimv's Avatar
    Join Date
    Sep 2010
    Location
    Chisinau, Moldova
    Posts
    642
    Vote Rating
    25
    vadimv will become famous soon enough vadimv will become famous soon enough

      0  

    Default


    thanks for suggestion, seems that it works

  5. #5
    Ext JS Premium Member prakashpaudel's Avatar
    Join Date
    May 2009
    Location
    Kathmandu, Nepal
    Posts
    58
    Vote Rating
    0
    prakashpaudel is on a distinguished road

      0  

    Default


    did this work for you guys??
    I am too having this issue

  6. #6
    Sencha Premium Member vadimv's Avatar
    Join Date
    Sep 2010
    Location
    Chisinau, Moldova
    Posts
    642
    Vote Rating
    25
    vadimv will become famous soon enough vadimv will become famous soon enough

      0  

    Default


    yes , is working 100%, just install the required packages with -pre on the gem install command. At least to have pre realease versions of :
    chunky_png compass haml sass

  7. #7
    Sencha User freewizard's Avatar
    Join Date
    Jan 2009
    Posts
    2
    Vote Rating
    0
    freewizard is on a distinguished road

      0  

    Default


    +1 yes
    also there's a bug in chunky_png prerelease prevent it from install properly last week.
    but it's fixed now.

Similar Threads

  1. rebuild the window
    By Stephan123 in forum Ext 3.x: Help & Discussion
    Replies: 4
    Last Post: 29 Sep 2009, 7:50 AM
  2. update/rebuild how to
    By sdetweil in forum Ext 1.x: Help & Discussion
    Replies: 0
    Last Post: 2 Apr 2008, 6:08 AM
  3. rebuild grid from array
    By agraves in forum Ext 1.x: Help & Discussion
    Replies: 2
    Last Post: 16 Oct 2007, 6:07 AM

Thread Participants: 3