Thanks for your responses.
I was installing all these different versions of chunky_png, and compass.
In the end, I ended up launching compass compile with
Code:
/var/lib/gems/1.9.1/bin/compass compile
Maybe this will help someone.