Hybrid View

  1. #1
    Sencha User nextSTEP's Avatar
    Join Date
    Sep 2010
    Posts
    36
    Vote Rating
    0
    nextSTEP is on a distinguished road

      0  

    Default [PR5] Portal not working properly

    [PR5] Portal not working properly


    Hallo,

    I took the code from the portal example of preview 5. I modified it, so that the portal extends from Ext.Panel instead of Ext.Viewport. I think that shouldn't be a problem.

    When I create this portal (then it gets rendered into a view port) Firefox tells:
    [Ext.Loader][not enabled] Missing required class: Ext.app.Portal
    . IE 9 creates and renders it perfectly without any error. What Am I doing wrong?

    Does it have something to do with MVC 3 (VS 2010) that I'm using? I also tried this within a normal aspx page. This works correctly in both browsers.

    I attached the solution if you are interested in this 'issue'.
    /Views/Shared/_Layout.cshtml contains all the script referencing, including the final "page script" which creates the portal.

    /Home is the MVC page that only works in IE.
    /WebForms1.aspx is the default aspx page that works in FF, too.

    I removed the ExtJS folder from the project due to file size. It's the original ExtJS download that I included into the project.

    Portal.zip

  2. #2
    Sencha User nextSTEP's Avatar
    Join Date
    Sep 2010
    Posts
    36
    Vote Rating
    0
    nextSTEP is on a distinguished road

      0  

    Default


    I started a new project using the new ExtJS 4 Beta 1 release.

    Now it seems to work everything, also in MVC 3 mode and normal Web Forms.
    I saw that the MVC view defined an HTML doctype, which I removed because I read somewhere that this might cause some problems with ExtJS 4..
    After I removed the doctype, just defining clear "html - head - body" tags everything worked fine.


    Tried to upload the new demo project, but failed to upload, 440 kb (unknown error).

Similar Threads

  1. regex not working properly
    By gauravk in forum Ext 2.x: Help & Discussion
    Replies: 5
    Last Post: 8 Jun 2009, 2:03 AM
  2. Replies: 9
    Last Post: 16 Apr 2009, 8:12 AM
  3. portal - how to properly include?
    By ibaniski in forum Ext 2.x: Help & Discussion
    Replies: 1
    Last Post: 7 Feb 2008, 6:44 AM
  4. Ajax not working properly, do not know why
    By Cyberangel67 in forum Ext 1.x: Help & Discussion
    Replies: 4
    Last Post: 4 Aug 2007, 6:14 PM