1. #51
    Sencha User 12ftguru's Avatar
    Join Date
    May 2007
    Posts
    22
    Vote Rating
    1
    12ftguru is on a distinguished road

      0  

    Default


    I am using the 2.1 code straight from the demo. Safari's Dom inspection is a little on the anemic side for now, but I am not seeing anything truly weird. One thing I did notice is that safari renders the buttons aligned to the top, while FireFox does their vertical align center.

    I am going to install the FirebugLite console and add in some console messages to see if I can figure it out. Any assistance/advice would be wonderful.

  2. #52
    Sencha User tjstuart's Avatar
    Join Date
    May 2007
    Location
    Sydney, Australia
    Posts
    310
    Vote Rating
    0
    tjstuart is on a distinguished road

      0  

    Default


    @curzonj re. Ext 2.0 compatibility - Eventually yes I will support Ext 2.0 but (unfortunately) I'm on a tight schedule at the moment so I cannot give a firm date. I have had a look at the 1.x->2.0 migration guide and it doesnt look like too much is involved in migrating custom widgets.

    @12ftguru re. Safari - I have done little testing on Safari. From your posts it would seem that the issues raised are cosmetic rather than functional. This is encouraging. I have the Safari beta 3 for Windows at work so will have a look tomorrow.

    @vtswingkid re. next release - The 2.2 release is mainly user submitted enhancements (such as yours) and a few bug fixes. I do like the idea of a filter for the available list and I would really like to add keyboard support but I can't guarantee either for 2.2

    Should have a release sometime this week.

  3. #53
    Sencha User galdaka's Avatar
    Join Date
    Mar 2007
    Location
    Spain
    Posts
    1,166
    Vote Rating
    -1
    galdaka is an unknown quantity at this point

      0  

    Default


    You have plain to migrate this extension for Ext 2.0?

  4. #54
    Sencha User tjstuart's Avatar
    Join Date
    May 2007
    Location
    Sydney, Australia
    Posts
    310
    Vote Rating
    0
    tjstuart is on a distinguished road

      0  

    Default


    Quote Originally Posted by galdaka View Post
    You have plain to migrate this extension for Ext 2.0?
    See my last post

  5. #55
    Sencha User tjstuart's Avatar
    Join Date
    May 2007
    Location
    Sydney, Australia
    Posts
    310
    Vote Rating
    0
    tjstuart is on a distinguished road

      0  

    Default Ext.ux.Multiselect/ItemSelector [v2.2]

    Ext.ux.Multiselect/ItemSelector [v2.2]


    Ext.ux.Multiselect/ItemSelector [v2.2] is now available.

    This release contains many enhancements most of which have come from other users.

    I have acknowledged these folks below and on the demo page @ http://www.figtreesystems.com/ext/ex...ltiselect.html

    The demo page now lists all available config options.

    Note for Safari users ... I have done some testing with the Safari 3.0.3 beta for Windows and have found no problems.

    @vtswingkid - I have tested all of your enhancements except for the fieldset/legend stuff. Again, many thanks for your efforts.



    PHP Code:
    // 2.2      Changes                      30 Oct 2007             Figtree Systems
    //                                                               vtswingkid/Valcom Inc.
    //                                                               paran01d/Grox Pty Ltd                                                                            
    //         Fixes/Enhancements
    //          - General
    //            - can now add toolbars to Multiselect and ItemSelector lists
    //            - can now change the delimiter for getValue()
    //            - fieldset and legend support
    //          - ItemSelector
    //            - optional 'clear' button for selected list
    //            - support for local sorting of the available and selected lists
    //            - can now change the path for the navigation icons
    //            - can now choose which navigation icons to display
    //            - added 'change' and 'rowdblclick' events
    //            - support for duplication in the selected list
    //          - DDView
    //            - modified to allow duplication 

  6. #56
    Ext JS Premium Member
    Join Date
    Mar 2007
    Location
    Virginia, USA
    Posts
    490
    Vote Rating
    -1
    vtswingkid is on a distinguished road

      0  

    Default


    Just real quick.

    My DDView changes didn't make it into the 2.2.zip

    You might update the header on the first message to 2.2

    Might put a link to the zip in there too...
    http://www.figtreesystems.com/ext/ex...lector-2.2.zip
    The download link points to 2.1.zip

    Might help to put a direct link to the download on the extensions page too.

    And thanks for your work!

  7. #57
    Sencha User 12ftguru's Avatar
    Join Date
    May 2007
    Posts
    22
    Vote Rating
    1
    12ftguru is on a distinguished road

      0  

    Default


    Thanks for the update. The built in options help a lot. Sadly Safari for Mac is still making babies cry (See Attached). Since you don't have a Mac to test with, I will dig into it and see if I can figure out what brand of crack Safari is smoking. Any starting points would be appreciated. Should I start with the css or the table structure in the code?

    Thanks,
    John
    Attached Images

  8. #58
    Sencha User 12ftguru's Avatar
    Join Date
    May 2007
    Posts
    22
    Vote Rating
    1
    12ftguru is on a distinguished road

      0  

    Default


    Nevermind... I am such a dork. It's working fine in Mac Safari. I missed one of the files when I copied the new one over. My bad.

    Thanks so very much.

  9. #59
    Sencha User tjstuart's Avatar
    Join Date
    May 2007
    Location
    Sydney, Australia
    Posts
    310
    Vote Rating
    0
    tjstuart is on a distinguished road

      0  

    Default


    Quote Originally Posted by vtswingkid View Post
    My DDView changes didn't make it into the 2.2.zip
    Whoops. Seems my copy/paste skills are not what they once were 2.2 archive now updated.

    Quote Originally Posted by vtswingkid View Post
    You might update the header on the first message to 2.2
    You mean the thread title? How does one do that? I've been wondering this for a while. Bet it's obvious but I cannot find.

    Quote Originally Posted by vtswingkid View Post
    The download link points to 2.1.zip
    Well spotted. Fixed.

    Quote Originally Posted by vtswingkid View Post
    Might help to put a direct link to the download on the extensions page too.
    Will do.

    Quote Originally Posted by vtswingkid View Post
    And thanks for your work!
    No problem

  10. #60
    Sencha User tjstuart's Avatar
    Join Date
    May 2007
    Location
    Sydney, Australia
    Posts
    310
    Vote Rating
    0
    tjstuart is on a distinguished road

      0  

    Default


    Just found a small bug with markInvalid for ItemSelector 2.2. I'll try patch it today or tomorrow.

film izle

hd film izle

film sitesi

takipci kazanma sitesi

takipci kazanma sitesi

güzel olan herşey

takipci alma sitesi

komik eğlenceli videolar