1. #11
    Sencha Premium Member
    Join Date
    May 2010
    Location
    Guatemala, Central America
    Posts
    1,306
    Vote Rating
    109
    ssamayoa is just really nice ssamayoa is just really nice ssamayoa is just really nice ssamayoa is just really nice

      0  

    Default


    Are you sure you disabled it at project level?

    Before I went to netbeans I was using Indigo, this is the builder's page of my ExtJS project:

    sencha5.png

    And this is the "about" of my indigo:

    sencha6.jpg

    Are you using spket plugin?
    I start using it but the benefits were to marginal so I decided to get rid of it.

    Regards.
    UI: Sencha Architect 3.x / ExtJS 4 & 5
    Server side: JEE / EJB 3.x / CDI / JPA 2.x/ JAX-RS / JasperReports
    Application Server: Glassfish / WildFly
    Databases: Oracle / DB2 / MySQL / Firebird

    If you like my answer please vote!

  2. #12
    Sencha User
    Join Date
    Sep 2011
    Posts
    9
    Vote Rating
    0
    supermarcos is on a distinguished road

      0  

    Thumbs up Spekt

    Spekt


    Hi, ssamayoa!

    Sorry for the delayed answer...
    I did install the Spekt JavaScript editor plug-in and now all works perfectly.

    Thank so much por the help!

    To other people that could have the same problem (I did that):
    1.- option menu "help" in Indigo -> "install new software"
    2.- add "http://www.spekt.com/update" and install all plugins
    4.- download the "*.jsb2" file from sencha web (I found it in the forums...)
    5.- put the jsb2 file in the extjs root (side by side of the ext-all.js file, for example)
    6.- in "window" option in the menu, in suboption "preferences" we need to create a "Javascript profile" for "ExtJs" in the "spekt" option: click on "new" (name: Ext"), select the new option "Ext", then click in "add library" button (select ExtJs in the list) then select the new option and clic in "add file" and explore to find the jsb2 file.
    7.- in "general" -> "editors" -> "file asociations" search "*.js" extension, select it and select in the list of editors that you have installed the "Spekt JavaScript Editor" and click in the "default" button (that option is in "window" -> "preferences", too)
    8.- Restart the IDE if necessary...
    9.- the end

  3. #13
    Sencha User
    Join Date
    Sep 2012
    Posts
    2
    Vote Rating
    0
    AnnaS17 is on a distinguished road

      0  

    Default


    Hi everyone,

    a view days ago I tried to create a Web-Project with ExtJS in Eclipse (Juno) for a student research project. There had never been any problems creating other Web-Projects in Eclipse until I tried to use ExtJS 4 (ext-4.1.1-gpl.zip) within my project.

    When I imported the (zipped or unzipped) ExtJS-folder into my project I had the same problem which is described at the beginning of this discussion by arnoldc. Eclipse simply stuck in “Building workspace” and eventually dies out with java heap space error.

    Tried virtually every solution I could find on the web:
    • Moved sdk.jsb3 from “extjs-4.1.1/build” to “extjs-4.1.1” and remapped wrong path specifications “../platform/” to “src” (and “src/src” to “src”)
    • Installed “Spket-PlugIn” for ExtJS and replaced “com.spket.js_1.6.23.jar” with the latest version
    • Configured an ExtJS-4 Profile via Spket-PlugIn for the customized sdk.jsb3-file and used “Spket JavaSkript Editor” as default for *.js
    • Modified eclipse.ini up to -Xms256m -Xmx4096m
    But nothing changed.

    My Question: Is there something more to do that I missed or did I do something wrong?
    Would be grateful for any idea (beside switching to another IDE).

    Best Regards.

  4. #14
    Sencha Premium Member
    Join Date
    May 2010
    Location
    Guatemala, Central America
    Posts
    1,306
    Vote Rating
    109
    ssamayoa is just really nice ssamayoa is just really nice ssamayoa is just really nice ssamayoa is just really nice

      0  

    Default


    I'm currently using Juno with ExtJS without problem.

    First, I suggest you to disable JavaScript builder:

    e1.png

    Then, instead of putting whole ExtJS distribution just include whatever you need, for example this is the structure of my WebContent:

    e2.png

    Note that my html entry pages includes ext-all or ext-all-debug.

    Regards.
    UI: Sencha Architect 3.x / ExtJS 4 & 5
    Server side: JEE / EJB 3.x / CDI / JPA 2.x/ JAX-RS / JasperReports
    Application Server: Glassfish / WildFly
    Databases: Oracle / DB2 / MySQL / Firebird

    If you like my answer please vote!

  5. #15
    Sencha User
    Join Date
    Sep 2012
    Posts
    2
    Vote Rating
    0
    AnnaS17 is on a distinguished road

      0  

    Default


    Hi ssamayoa,

    thank´s for posting the structure of your WebContent. I wasn´t entirely sure which files and folders are important, so I put the whole ExtJS distribution into my project. This time I put one file after another into my project and just the one you suggested. I even tried it without disabling JavaScript builder (thought this would reduce my Eclipse to an ordinary text-editor).

    The first time I imported ext-all-debug.js (or ext-all.js) into the project it took a little while until “Building Workspace” was finished. But every further time “Building Workspace” works fine.

    Thank´s a lot for the tip of using ext-all.js or ext-all-debug.js instead of ext-debug.js in html entry pages, too. Just ask myself why ext-debug is recommended for the pages under http://www.sencha.com/learn/getting-...rted-section-2 and what is it good for? (Maybe I will find out later)

    Finally I successfully created a first “Hello Ext”.

    (Also it works with the original eclipse.ini file. So, for a start, there is no need to crank up memory.)

    Best Regards.