Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Ext JS Premium Member
    Join Date
    May 2010
    Posts
    13
    Vote Rating
    0
    tbaenziger is on a distinguished road

      0  

    Default rowexpander does not work

    rowexpander does not work


    pls try to expand row in the 1st grid in Grid Plugins Examples

    in my application
    Error message this.view is undefined
    in examples/ux/RowExpander.js row 179
    var rowNode = this.view.getNode(rowIdx),

    expand row does not work in ext 4.0.2a! why ?
    changed back to 4.0.1 there it is working

    kind regards Thomas

  2. #2
    Sencha User loiane's Avatar
    Join Date
    Aug 2009
    Posts
    184
    Vote Rating
    53
    loiane is a jewel in the rough loiane is a jewel in the rough loiane is a jewel in the rough

      0  

    Default


    The plugin in 4.01 version also does not work if you don't set a height for the grid.
    Sencha/Java evangelist
    Author of ExtJS 4 First Look and Mastering Ext JS books
    English blog: http://loianegroner.com
    Portuguese blog: http://loiane.com
    Sencha Examples: https://github.com/loiane

  3. #3
    Sencha - Ext JS Dev Team Animal's Avatar
    Join Date
    Mar 2007
    Location
    Notts/Redwood City
    Posts
    30,508
    Vote Rating
    56
    Animal has a spectacular aura about Animal has a spectacular aura about Animal has a spectacular aura about

      0  

    Default


    Thanks! Both of these are fixed for 4.0.5

  4. #4
    Sencha Premium Member
    Join Date
    May 2010
    Location
    Guatemala, Central America
    Posts
    1,310
    Vote Rating
    112
    ssamayoa is just really nice ssamayoa is just really nice ssamayoa is just really nice ssamayoa is just really nice ssamayoa is just really nice

      0  

    Default


    Quote Originally Posted by Animal View Post
    Thanks! Both of these are fixed for 4.0.5
    When will be released?

    Regards.
    UI: Sencha Architect 3.x / ExtJS 4 & 5
    Server side: JEE / EJB 3.x / CDI / JPA 2.x/ JAX-RS / JasperReports
    Application Server: Glassfish / WildFly
    Databases: Oracle / DB2 / MySQL / Firebird

    If you like my answer please vote!

  5. #5
    Sencha - Community Support Team edspencer's Avatar
    Join Date
    Jan 2009
    Location
    Palo Alto, California
    Posts
    1,939
    Vote Rating
    9
    edspencer is a jewel in the rough edspencer is a jewel in the rough edspencer is a jewel in the rough

      0  

    Default


    Quote Originally Posted by ssamayoa View Post
    When will be released?

    Regards.
    4.0.5 is a support subscriber release and is expected to go out in approximately 1 week
    Ext JS Senior Software Architect
    Personal Blog: http://edspencer.net
    Twitter: http://twitter.com/edspencer
    Github: http://github.com/edspencer

  6. #6
    Ext JS Premium Member
    Join Date
    Oct 2009
    Posts
    8
    Vote Rating
    0
    JanvandeKlok is on a distinguished road

      0  

    Default Up and down component query fails when rowexpander is used

    Up and down component query fails when rowexpander is used


    The up and down expects the isXType(x,y) on components.

    The rowExpander HeaderConfig object is missing this method , causing the up() and down() methods to crash.

    see also my other post http://www.sencha.com/forum/showthre...383#post625383


    Jan