Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha User
    Join Date
    Feb 2011
    Posts
    1
    Vote Rating
    0
    archidus is on a distinguished road

      0  

    Default Unanswered: Issues when series are hidden or shown

    Unanswered: Issues when series are hidden or shown


    Hello,

    I have a problem, which I found on area and bar charts (which can be seen in Touch Charts Beta's Area / Bar example)... Whenever a series is selected from the legend, it disappears/appears but it also moves the other series's points a bit, without changing the axis' scale....

    For example:
    In the Area example from Touch Charts, if you remove the one topmost series, the 6 others expand a bit while the values on the Y Axis remain the same...
    Looking at the seven series together, the first six ones got to, for example, about X. If the seventh series is hidden, the first six ones get to an easy-to-notice different value from X. This doesn't seem to happen all the time, though.



    Also, another issue related to that...
    If I press the refresh/shuffle button with only one series selected, the chart is rendered as if the sum of all seven would be the value of that single visible series.

    I had an example where I had 4 Area series, all of them with two values: [ 0, 5 ] . Hiding all of them except the blue one (the first) and refreshed the chart with the same values, it's last value was at the '1.25' in the Y axis, and after I put them all to visible state, it reached 5 (instead of the total 20 that would appear when I refreshed the chart with all of them visible).


    The same problems happen on bar charts.... It seems like it is not specific to series, but to the series' manipulation by the legend.

  2. #2
    Sencha - Architect Dev Team jjohnston's Avatar
    Join Date
    Sep 2010
    Posts
    461
    Answers
    18
    Vote Rating
    15
    jjohnston will become famous soon enough jjohnston will become famous soon enough

      0  

    Default


    Thank you for reporting this, I can verify that it is an issue. We have logged this internally and it will be fixed.

Thread Participants: 1