Currently the latest available version is 2.2.0 and it's not working with GWT 2.2 due to the class change error:

Code:
java.lang.IncompatibleClassChangeError: Found interface com.google.gwt.core.ext.typeinfo.JClassType, but class was expected
I locally installed 2.2.4 and that works fine. Would be great if you guys could maintain GXT in Maven as well.