1. #1
    Sencha User
    Join Date
    May 2008
    Posts
    19
    Vote Rating
    0
    samsonasu is on a distinguished road

      0  

    Default Unanswered: Buttons, boxWrap, and IE

    Unanswered: Buttons, boxWrap, and IE


    When I make a Ext.Button, it renders in the 9-cell html table "boxWrap" only in IE. I read a bunch of source code and I cannot figure out where//how it decides to do this.

    It would be great if I could disable this because I'm doing some custom styling on the buttons I'd prefer not to have to style another 9 elements to change the background color of the button + hover, pressed, etc.

  2. #2
    Sencha Premium Member skirtle's Avatar
    Join Date
    Oct 2010
    Location
    UK
    Posts
    3,624
    Vote Rating
    331
    Answers
    550
    skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future

      0  

    Default


    It's mostly in AbstractComponent.

    The markup is frameTableTpl.

    onRender() -> initFrame() -> getFrameTpl()

    Hopefully that'll get you started. Obviously it wouldn't be wrapping it in a table without good reason. Maybe the styling you're doing doesn't need the table, in which case turning it off would make sense.

  3. #3
    Sencha User
    Join Date
    Aug 2011
    Location
    Singapore
    Posts
    21
    Vote Rating
    1
    zhenrong is on a distinguished road

      0  

    Default


    Hi,

    I too faced this issue. Setting frame: false on the button doesnt work at all. Is this a bug or something? I am on version 4.0.6.


    Thanks!

  4. #4
    Sencha Premium Member skirtle's Avatar
    Join Date
    Oct 2010
    Location
    UK
    Posts
    3,624
    Vote Rating
    331
    Answers
    550
    skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future skirtle has a brilliant future

      0  

    Default


    Take a look at the end of the method getFrameInfo() in AbstractComponent. Looks like setting it to false won't help. You might be able to override that method in a subclass and just return false without calling the parent implementation. Haven't tried it but I'd imagine that'd do it.

    To reiterate my earlier point, removing the frame could cause carnage in older versions of IE so only do it if your alternative styling will cope with that.

Thread Participants: 2