1. #1
    Sencha User
    Join Date
    Oct 2011
    Posts
    4
    Vote Rating
    0
    vladimirv is on a distinguished road

      0  

    Default Unanswered: Parse error - There is a problem parsing the package

    Unanswered: Parse error - There is a problem parsing the package


    Sorry->Move this message to Sencha Touch forum group Q&A

    Hello,

    I have created Android application using PhoneGap and Sencha Touch 1.1

    When I test the application, on several phones I get an error:

    Parsing Error:
    There is a problem parsing the package

    What could be the problem?
    The OS of the phone that throws error:
    * Android 2.1 upgraded from 1.6
    * Android 2.3.3
    Application is compiled to work on Android v2.1

    Thanks.
    Last edited by vladimirv; 7 Nov 2011 at 5:58 AM. Reason: Wrong forum group

  2. #2
    Sencha - Senior Forum Manager mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    37,346
    Answers
    3541
    Vote Rating
    847
    mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute

      0  

    Default


    This seems to be because of PhoneGap and the packaging it does. Can't really help with that info.
    Mitchell Simoens @SenchaMitch
    Sencha Inc, Senior Forum Manager
    ________________
    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  3. #3
    Sencha User siebmanb's Avatar
    Join Date
    Aug 2011
    Location
    Geneva (CH) - Grenoble (FR)
    Posts
    253
    Answers
    11
    Vote Rating
    16
    siebmanb will become famous soon enough

      1  

    Default


    It may be because of the way you send the app to the phone. I used to use email and Android Mail app to read the apk. It used to work but since the last update of the app, it doesn't. However Gmail works fine.

  4. #4
    Sencha User
    Join Date
    Jul 2012
    Posts
    2
    Vote Rating
    0
    Ramnivas is on a distinguished road

      0  

    Default


    yes this problem occurs when we send our mail through gmail or any mail system and download it through android app, I have seen these problem on Android version 2.1 with native development as well.

  5. #5
    Sencha User
    Join Date
    May 2013
    Posts
    37
    Answers
    3
    Vote Rating
    1
    kidmanmatch is on a distinguished road

      0  

    Default Fixed Parsing error

    Fixed Parsing error


    Hi,

    I have also faced this problem, in my case its because of the androidAPILevel, in my packager.json file i gave api version 17 bug my phone is only 15, so i got a error message "There is problem in parsing the package".
    Thanks