1. #1
    Sencha User
    Join Date
    Dec 2010
    Location
    Toronto
    Posts
    62
    Vote Rating
    1
    thomsonzh is on a distinguished road

      0  

    Default Extjs 4 intellisense in visual studio 2010

    Extjs 4 intellisense in visual studio 2010


    Hi,

    Is anybody know how to setup extjs 4 intellisense in vs2010?

    Thanks
    Thomson

  2. #2
    Sencha User
    Join Date
    Oct 2011
    Posts
    1
    Vote Rating
    0
    bgautard is on a distinguished road

      0  

    Default


    I'm looking for it too !

    Thanks everbody.
    Ben

  3. #3
    Sencha User
    Join Date
    Oct 2011
    Posts
    2
    Vote Rating
    0
    andyattogether is on a distinguished road

      0  

    Default Has anyone out there got this working?

    Has anyone out there got this working?


    I'm also having problems with Visual Studio 2010 and intellisense and ExtJS 4.0

    There are a lot of posts on the internet mainly regarding VS 2008 but none of them work for me.

    Just an indication that someone out there has this working would be a good start!

  4. #4
    Touch Premium Member bsbal's Avatar
    Join Date
    Oct 2011
    Location
    Basel, Switzerland
    Posts
    32
    Vote Rating
    0
    bsbal is on a distinguished road

      0  

    Cool Intellisence in VS2010

    Intellisence in VS2010


    Just add the following line to your JS File:

    /// <reference path="file://C:/workspace/ExtJS/ext-all-debug-w-comments.js" />

    (Path to your ext library)

    After that press Ctrl + Shift + J to refresh intellisense. (wait few seconds...)

    That's it.

  5. #5
    Sencha User
    Join Date
    May 2010
    Posts
    7
    Vote Rating
    0
    francorobles is on a distinguished road

      0  

    Default


    Intellisense won't show up for properties inside a constructor.
    VS2010ExtIntellisense.png

  6. #6
    Sencha User
    Join Date
    Nov 2011
    Location
    Toronto
    Posts
    105
    Vote Rating
    2
    basememara is on a distinguished road

      0  

    Default


    I know you are asking for Visual Studio, but check out WebStorm. It has intellisense for Ext JS and is the best IDE for Javascript.

  7. #7
    Sencha User
    Join Date
    Mar 2012
    Posts
    1
    Vote Rating
    0
    Rochelle is on a distinguished road

      0  

    Default So we are saying Intellisense for ExtJS 4 in Visual Studio 2010 Does or Doesn't work?

    So we are saying Intellisense for ExtJS 4 in Visual Studio 2010 Does or Doesn't work?


    Thanks for suggestion of Webstorm. I know there is also NetBeans but trying to work within our current set of Dev tools - ie Visual Studio.

    I have tried adding the following suggested reference directives to the top of my js file doing a CTRL-SHIFT-J to refresh.

    /// <reference path="../ExtJS/ext-all-debug.js" />

    I tried ext-all-debug-w-comments.js and also ext-all-debug.js which appears to be the "new" ext_base.js which was mentioned in a lot of other posts/forums.

    I still have no luck on getting anything on typing Ext. Is this it or is my Intellisense not working and doesn't have the support in VS2010 ?


    A tool with a few nice features I found mentioned in another post that might be useful to some also was
    http://visualstudiogallery.msdn.microsoft.com/872d27ee-38c7-4a97-98dc-0d8a431cc2ed


    Cheers


  8. #8
    Sencha User
    Join Date
    Jan 2012
    Posts
    1
    Vote Rating
    1
    Peepa is on a distinguished road

      1  

    Default Try to check JScript IntelliSense errors in the Output tab of VS2010

    Try to check JScript IntelliSense errors in the Output tab of VS2010


    Hi,
    this solution works with ext3.4/VS2010 but may be you have the same problem with ext4.0.
    After refreshing your intellisense (CTRL+SHIFT+J), try to check out the Output tab.
    When I've got the reference set just to:
    Code:
    /// <reference path="~/ext-3.4.0/ext-all-debug-w-comments.js" />
    I've got a lot of these messages there:
    Javascript Intellisense Message: C:\AFW\TExI\UI\ext-3.4.0\ext-all-debug-w-comments.js(55411:0) : 'Ext' is undefined
    The Ext namespace is simply not defined in ext-all*.js file. So adding the ext-base script to have the namespaces fixed the problem:
    Code:
    /// <reference path="~/ext-3.4.0/adapter/ext/ext-base.js" />
    /// <reference path="~/ext-3.4.0/ext-all-debug-w-comments.js" />
    And after another refresh of intelliSense it works like a charm.
    hth

  9. #9
    Sencha User
    Join Date
    Nov 2012
    Posts
    7
    Vote Rating
    0
    yuhanlee is on a distinguished road

      0  

    Default


    hi, for all who want to add intellisense to VS2010, apparently the problem is only with the "path". Try the full path, eg : "C:\Inetpub\wwwroot\website\ext-all-dev.js" , it works like a charm!!

  10. #10
    Sencha User
    Join Date
    Jul 2012
    Posts
    21
    Vote Rating
    2
    hlurger is on a distinguished road

      0  

    Default Got it working....

    Got it working....


    Hi,
    I am still using VS 2008 to change a little bit in the ext-all-debug-w-comments.js....

    I added following line on the top of my js-file (like all the other...):
    Code:
    /// <reference path="C:\dev\kostenmanagement\kmm\ext-4\ext-all-debug-w-comments.js" />
    The problem was, that when I hit CTRL-SHIFT-J, I got one error in the output window ('src' is null or undefined on line 10083)

    The solution for me was, that I simple removed the whole function, saved it (you probably want to save it under a new name) and pressed CTRL-SHIFT-J again! Now it is working!!

    Code:
    // initalize the default path of the framework
    (function() {
        var scripts = document.getElementsByTagName('script'),
            currentScript = scripts[scripts.length - 1],
            src = currentScript.src,
            path = src.substring(0, src.lastIndexOf('/') + 1),
            Loader = Ext.Loader;
    
    
    
    
        Loader.setConfig({
            enabled: true,
            disableCaching: true,
            paths: {
                'Ext': path + 'src'
            }
        }
    );
    })();