1. #1
    Sencha User realjax's Avatar
    Join Date
    Aug 2009
    Location
    Netherlands
    Posts
    412
    Vote Rating
    6
    realjax is on a distinguished road

      0  

    Default Unanswered: Ext.is deprecated

    Unanswered: Ext.is deprecated


    I am porting a project from from Touch 1.1 to 2 and (of course) face problems. One of them is this:

    Ext.is
    is apparently gone. Sencha calls it 'deprecated', but without prior notice removing support from one version to the next is not deprecation in my book..

    Going through the sources it turns out this is replaced by Ext.os.is
    Any documentation available anywhere? A search through the touch 2.0 api docs revealed zilch...
    twitter: @realjax

  2. #2
    Sencha User realjax's Avatar
    Join Date
    Aug 2009
    Location
    Netherlands
    Posts
    412
    Vote Rating
    6
    realjax is on a distinguished road

      0  

    Default


    Ext.env is what I think am supposed to be looking at in the API docs, but it looks rather unfinished to me..
    twitter: @realjax

  3. #3
    Sencha - Sencha Touch Dev Team Jacky Nguyen's Avatar
    Join Date
    Jul 2009
    Location
    Palo Alto, California
    Posts
    469
    Answers
    24
    Vote Rating
    13
    Jacky Nguyen has a spectacular aura about Jacky Nguyen has a spectacular aura about

      0  

    Default


    Ext.is and Ext.supports are both deprecated. However they still exists for backwards-compatibility in the debug builds, and you should see proper warning messages in the debugger console if you access their properties, for example: accessing Ext.is.WebKit will gives you this message:

    Code:
    [DEPRECATE] Ext.is.WebKit is deprecated, please use Ext.browser.is.WebKit instead
    Make sure you're developing with sencha-touch-debug.js (or sencha-touch-all-debug.js). Warning messages are stripped out in production builds.
    Sencha Touch Lead Architect

  4. #4
    Sencha User realjax's Avatar
    Join Date
    Aug 2009
    Location
    Netherlands
    Posts
    412
    Vote Rating
    6
    realjax is on a distinguished road

      0  

    Default


    Quote Originally Posted by Jacky Nguyen View Post
    Ext.is and Ext.supports are both deprecated. However they still exists for backwards-compatibility in the debug builds..
    Not entirely backwards compatible. I had some extras stashed in the Ext.is.platforms array, but that code now breaks because the platforms array seems to be non existent. Bummer.
    twitter: @realjax

Thread Participants: 1

film izle

hd film izle

film sitesi

takipci kazanma sitesi

takipci kazanma sitesi

güzel olan herşey

takipci alma sitesi

komik eğlenceli videolar