1. #1
    Sencha User
    Join Date
    Sep 2011
    Location
    Angers, France
    Posts
    6
    Vote Rating
    1
    pgy49 is on a distinguished road

      0  

    Default Unanswered: GXT 3.0, Designer and Eclipse

    Unanswered: GXT 3.0, Designer and Eclipse


    Hello,

    I try to use the designer view with Eclipse (Indigo version), but every example that I try, I have the following error:
    Code:
    Error loading module(s).
    GWT Designer can't load a module because of error in gwt.xml module  description, incorrect resource which requires processing with GWT generator or  by some other configuration error.
     Please check your $project_dir/.gwt/.gwt-log for GWT-specific errors  (not GWT Designer errors).
    This log has the following error messages:
    
    [ERROR] Error occured loading property:   
    [ERROR] Deferred binding failed for 'com.sencha.gxt.core.client.GXT.UserAgent'; expect subsequent failures
    [ERROR] Failed to create an instance of 'com.sencha.gxt.widget.core.client.container.FlowLayoutContainer' via deferred binding
    In my buildpath I have the gxt-3.0.0-SNAPSHOT and the uibinder-bridge-2.4.0.
    Do I need to configure something else ?

    Thanks for your help !

  2. #2
    Sencha Premium Member
    Join Date
    Feb 2011
    Location
    Amsterdam
    Posts
    54
    Vote Rating
    -6
    sblommers is infamous around these parts sblommers is infamous around these parts

      0  

    Default


    Hi there!

    I doubt you will get the designer to work (at this time). I tried that as well, I don't think it is supported just yet. But still I ran into the same problem as you did and I added these lines to the gwt.xml

    <set-property name="gxt.user.agent" value="chrome" />
    <set-property name="user.agent.os" value="linux" />

    I don't think this is a fix but it might help you to get to the next step.

    Good luck!

    Sebastiaan

  3. #3
    Sencha User
    Join Date
    Sep 2011
    Location
    Angers, France
    Posts
    6
    Vote Rating
    1
    pgy49 is on a distinguished road

      0  

    Default


    Thanks, it's better with these lines (no more error) !

Thread Participants: 1