Success! Looks like we've fixed this one. According to our records the fix was applied for TOUCH-1157 in a recent build.
  1. #1
    Ext JS Premium Member
    Join Date
    Jan 2011
    Posts
    83
    Vote Rating
    2
    danCTS is on a distinguished road

      0  

    Default Viewport is not fullscreen on HTC Desire

    Viewport is not fullscreen on HTC Desire


    I am developing a web app in ST2 PR2 and it has whitespace at the bottom of the screen on my HTC Desire when using a fullscreen viewport. I thought it may have been my code, but the same thing happens if I view your kitchen sink demo on your website on my HTC Desire. My phone is running Android 2.3.3 Gingerbread. I also tried resetting the browser on the phone to default settings and that did not help. This whitespce is present at the bottom of the screen in landscape and portrait views on the phone.

  2. #2
    Sencha User Jamie Avins's Avatar
    Join Date
    Mar 2007
    Location
    Redwood City, California
    Posts
    3,661
    Vote Rating
    19
    Jamie Avins is a jewel in the rough Jamie Avins is a jewel in the rough Jamie Avins is a jewel in the rough

      0  

    Default


    I have seen the same behavior on that device as well. I believe we have an open issue internally on it, but just to make sure we'll open this one as well.

    Sencha Inc

    Jamie Avins

    @jamieavins

  3. #3
    Sencha - Sencha Touch Dev Team rdougan's Avatar
    Join Date
    Oct 2008
    Posts
    1,158
    Vote Rating
    6
    rdougan will become famous soon enough

      0  

    Default


    This is down the to autoMaximize method in Ext.Viewport which tries to hide the address bar when it exists.

    In the next release we have decided to change the default value of this to false, instead of true. There are just too many situations where there are issues with the viewport not expanding. Not to mention the fact that the performance is slightly worst when it is enabled.

    If you ever want to enable it in your application int he future, you can use the following configuration in Ext.setup or Ext.application:

    Code:
    Ext.setup({
        viewport: {
            autoMaximize: true
        },
        onReady: function() {
            //...
        }
    });
    Thanks for the report!
    Sencha Inc.
    Robert Dougan - @rdougan
    Sencha Touch 2 and Ext JS 4 Core Team Member, SASS/Theming Wizard.

Thread Participants: 2