Success! Looks like we've fixed this one. According to our records the fix was applied for DSIGNERONE-12 in a recent build.
  1. #1
    Sencha User
    Join Date
    Dec 2009
    Posts
    5
    Vote Rating
    0
    deaconb is on a distinguished road

      0  

    Default TreePanel and TreeStore problems when opening 1.1.2 project with 1.2.2 Build 48

    TreePanel and TreeStore problems when opening 1.1.2 project with 1.2.2 Build 48


    Trying to open one of our 1.1.2 projects in Designer 1.2.2 Build 48 and encountering the following error:

    An unexpected error occurred
    Please help us make Designer better by reporting this error to the Designer forums
    TypeError: 'undefined' is not an object
    Restart Exit Designer
    Based on other posts I've found in the forums, I'm guessing the problem lies in one of our class definitions, but I have no indication of where the problem lies. Is there any way to run Designer in a debug or enhanced logging mode so that I can actually see where the error is occuring?

    Thanks

  2. #2
    Sencha Premium Member lorezyra's Avatar
    Join Date
    Dec 2007
    Location
    Japan -- 日本
    Posts
    634
    Vote Rating
    15
    lorezyra will become famous soon enough lorezyra will become famous soon enough

      0  

    Thumbs up debug console

    debug console


    I like that idea! Perhaps we should request a feature in Designer where we can see a debug console!?
    Perfection as a goal is a nice idea that can point one in a specific direction. However, since "perfection" is an ever changing (evolving?) and moving target, one must admit that perfection can never be obtained...

    When in doubt, check the d4mn source code!
    ================================================
    And here are my terms...
    1. I don't care if you use my source code. (Known as "Code.")
    2. I don't care if I get any monetary compensation.
    3. I do care to receive credit for Code provided. So, please keep my name in the comments for Code provided.
    4. Code is provided without warranty "AS-IS" and I claim absolutely no warranty nor liability to the quality, security, and run-ability on any platform.
    5. By using Code, you accept all risk inherit with Code regardless if Code has known and yet to be discovered bugs.
    6. You are welcome to change and improve the Code to best meet your needs.
    7. I don't care if you use the Code in a commercial or open-source project.
    8. You are not required to contact me prior to using the Code.
    ================================================
    Simple. Enjoy.

  3. #3
    Sencha User
    Join Date
    Sep 2010
    Posts
    13
    Vote Rating
    0
    ryanrca is on a distinguished road

      0  

    Default


    I too would like to put in a strong request for debugging, or just some logging.

    I am getting the exact same error, the only options are to restart or exit designer.

    This is happening when I load data into my harness tree store.

    I'm on designer on 1.2.2 build 48 on CentOS linux (32 bit) version 5.5. I'm trying to build an ExtJS 4.0 project, but not getting very far.

    I have no idea where to begin troubleshooting. When I make the exact same request into a browser, I get well defined JSON output. Help!

  4. #4
    Sencha User
    Join Date
    Sep 2010
    Posts
    13
    Vote Rating
    0
    ryanrca is on a distinguished road

      0  

    Default I have a reproduction vector

    I have a reproduction vector


    Here's exactly what I did to cause this to occur:

    1) Start a new project in the designer.
    2) Add a tree panel
    3) Create a new JSON Tree Store, add URL, fields etc.
    5) associate the tree panel with the new tree store. Click "Load Data"

    The project up to now behaves as expected. It works. I am seeing my data in the tree view.

    Now, go File | Save project as...
    Exit designer.
    RE-start designer and open recent project.

    Now, when I click "load data" in the Tree store, I get the said error.

    "TypeError: 'undefined' is not an object" opening 1.1.2 project with 1.2.2 Build 48:


  5. #5
    Sencha User
    Join Date
    Sep 2010
    Posts
    13
    Vote Rating
    0
    ryanrca is on a distinguished road

      0  

    Default


    it should be added that I see the data get loaded -- the tree populates, but instantly after that, the modal dialog box opens, and my only choices are to exit or restart.

  6. #6
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,198
    Vote Rating
    120
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    We are working on ways to improve the bug reporting. We are aware that right now the information that you get back is not very useful.

    Thanks for the above test case. We will try to reproduce it. It may also be helpful if you were to send your own project file which you are encountering the problem with.
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  7. #7
    Sencha User
    Join Date
    Dec 2009
    Posts
    5
    Vote Rating
    0
    deaconb is on a distinguished road

      0  

    Default


    Aaron, I'd be happy to send in my project file. What is the best method to get it to you?

  8. #8
    Sencha User
    Join Date
    Sep 2010
    Posts
    13
    Vote Rating
    0
    ryanrca is on a distinguished road

      0  

    Default


    Ive attached the simpliest project file I could create that reproduces the problem.
    To reproduce the problem, just load the project and go to the store tab and right-click and select "Load Data".

    It reproduces on CentOS 5.5 and on my mac running Lion.

    Of course you will need the server for the JSON. I also attached the output of the JSON my server produces.

    Thanks for taking a look!
    Attached Files

  9. #9
    Sencha User
    Join Date
    Dec 2009
    Posts
    5
    Vote Rating
    0
    deaconb is on a distinguished road

      0  

    Default


    Problem project file attached. The error occurs immediately upon opening the file.
    Attached Files

  10. #10
    Sencha User
    Join Date
    Sep 2010
    Posts
    13
    Vote Rating
    0
    ryanrca is on a distinguished road

      0  

    Default


    For fun I loaded deaconb's project file and the problem reproduces on both my environments.

    I wonder if we are experiencing the same problem. The error message is the same.