1. #1
    Sencha User
    Join Date
    Dec 2011
    Posts
    1
    Vote Rating
    0
    Matt S is on a distinguished road

      0  

    Default Unanswered: Reasons for requiring Java 1.6?

    Unanswered: Reasons for requiring Java 1.6?


    Sencha has stated "Following GWT’s deprecation of Java 1.5, ExtGWT also requires at least Java 1.6 to compile." Any particular reason Sencha chose to enforce this? Are there features in Ext GWT 3 that need Java 1.6?

    I ask because our company is still using Websphere App Server 6.1, which only supports Java 1.5. We are successfully using base GWT 2.3 with this environment. We would like to add ExtGWT3, but find some limits with GXT2. So the Java 1.6 requirement is causing some tough decisions. Of course, upgrading WAS to 7 is the best answer, but it looks like our company may not have all our environments ready by the time we hoped to deploy our GWT app (summer 2012).

  2. #2
    Sencha - GXT Dev Team
    Join Date
    Feb 2009
    Location
    Minnesota
    Posts
    2,732
    Answers
    109
    Vote Rating
    90
    Colin Alworth is a glorious beacon of light Colin Alworth is a glorious beacon of light Colin Alworth is a glorious beacon of light Colin Alworth is a glorious beacon of light Colin Alworth is a glorious beacon of light

      0  

    Default


    GXT 3 beta 1 works only with GWT 2.4.0 and up, which I believe is compiled for compat with JDK 1.6 and up. At the time we began GXT 3, GWT still allowed 1.5, it is not any longer.

    See https://groups.google.com/forum/#!to...it/fATw0rL8lSE for more information.

    We are requiring GWT 2.4.0 first because we are only at the beta stage and so do not want to introduce backward compatibility issues so eary, and because there are several changes and bug fixes provided only in 2.4 that were not made available in the 2.3 series.

Thread Participants: 1