Could you list the versions (and maybe download links?) for the other libraries you mention in your module file? If there is a bad interaction between GXT and those, it is bound to come up again.

* com.google.code.GwtEyeCandy
* com.google.gwt.resources.Resources
* com.mvp4g.Mvp4gModule

Can you also try a stripped down entrypoint that just adds a single, simple uibinder-based widget to the page, with the module you have now? That is how I will test this case, once I have the right versions for those libs, in lieu of your actual project.