1. #1
    Ext JS Premium Member Lloyd K's Avatar
    Join Date
    Oct 2007
    Location
    Brighton, United Kingdom
    Posts
    655
    Vote Rating
    1
    Lloyd K is on a distinguished road

      0  

    Question Flash & Z-Order

    Flash & Z-Order


    Hey quick query, I have my own portal thing going on with the code you supplied in examples and I have a Flash movie in the portlet, however Ext.MessageBox and the like appear UNDER the Flash, any way to resolve this?

  2. #2
    Ext JS Premium Member Lloyd K's Avatar
    Join Date
    Oct 2007
    Location
    Brighton, United Kingdom
    Posts
    655
    Vote Rating
    1
    Lloyd K is on a distinguished road

      0  

    Default


    No matter, "Ext.useShims = true" seems to have solved the issue.

  3. #3
    Ext JS Premium Member Lloyd K's Avatar
    Join Date
    Oct 2007
    Location
    Brighton, United Kingdom
    Posts
    655
    Vote Rating
    1
    Lloyd K is on a distinguished road

      0  

    Default


    Actually, this problem still affects Opera, any suggestions?

  4. #4
    Ext JS Premium Member corcoranp's Avatar
    Join Date
    Apr 2007
    Location
    Pleasant Grove, AL
    Posts
    25
    Vote Rating
    3
    corcoranp is on a distinguished road

      0  

    Default Still having this issue

    Still having this issue


    I'm having the same issue with the messagebox not displaying over the flash movie. Any ideas how this gets fixed. I tried Ext.useShims = true; but this didn't work for me...
    Peter M Corcoran

    ExtJs Developer since 2007
    www.corcoranp.com
    http://www.linkedin.com/in/corcoranp

  5. #5
    Ext JS Premium Member corcoranp's Avatar
    Join Date
    Apr 2007
    Location
    Pleasant Grove, AL
    Posts
    25
    Vote Rating
    3
    corcoranp is on a distinguished road

      0  

    Default Nevermind

    Nevermind


    I read an earlier post...

    here is the solution:
    add this line to flash object's params:
    <param name="wmode" value="opaque">

    and this parameter to <embed... tag
    wmode="opaque"


    or if you are using SWFObject as I am...
    swfobject.addParam("wmode", "opaque");

    FYI: I'm using this flv player:
    http://www.jeroenwijering.com/?item=JW_FLV_Player
    Peter M Corcoran

    ExtJs Developer since 2007
    www.corcoranp.com
    http://www.linkedin.com/in/corcoranp

  6. #6
    Ext JS Premium Member Lloyd K's Avatar
    Join Date
    Oct 2007
    Location
    Brighton, United Kingdom
    Posts
    655
    Vote Rating
    1
    Lloyd K is on a distinguished road

      0  

    Default


    Hey thanks for the heads up but as far as I can see this still affects me in Opera!

Thread Participants: 1